Modify

Opened 7 years ago

Closed 12 months ago

#2937 closed Bug (Works For Me)

TCPRecv() set @error to -1 when a telnet client connect on socket

Reported by: antoine@… Owned by:
Milestone: Component: AutoIt
Version: 3.3.12.0 Severity: None
Keywords: Cc:

Description

hello,

Autoit 3.3.12, TCPRecv () returns @error -1 when a telnet client connects to the socket.

Attachments (1)

telnet.au3 (4.9 KB) - added by antoine@… 7 years ago.
Server Telnet AutoIT for Test

Download all attachments as: .zip

Change History (3)

Changed 7 years ago by antoine@…

Server Telnet AutoIT for Test

comment:1 Changed 7 years ago by anonymous

tcprecv return @error -1 when buffer is empty

comment:2 Changed 12 months ago by Jpm

  • Resolution set to Works For Me
  • Status changed from new to closed

Hi I think the problem is closed just try the TCPSend/ TCPRecv second example using a big file

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.