Modify

Opened 6 years ago

Closed 6 years ago

#2944 closed Bug (Fixed)

MsgBox timeout not working

Reported by: richard.hopton@… Owned by: BrewManNH
Milestone: 3.3.13.20 Component: Documentation
Version: Other Severity: None
Keywords: msgbox timeout Cc:

Description

Hi

When I use either $MB_SERVICE_NOTIFICATION or $MB_DEFAULT_DESKTOP_ONLY flags (or the decimal/hex equivalents) for a msgbox, the timeout doesn't work.

eg

#include <MsgBoxConstants.au3>
MsgBox($MB_SERVICE_NOTIFICATION, "Title", "Text",10)

Does not timeout.

I am running Win7 32bit with the latest public release (3.3.12.0) and have tried the most recent Beta (3.3.13.19) but no joy.

Attachments (0)

Change History (3)

comment:1 Changed 6 years ago by BrewManNH

  • Component changed from AutoIt to Documentation
  • Version 3.3.12.0 deleted

As stated in the thread this was originally brought up in:

http://www.autoitscript.com/forum/topic/165858-message-box-timeout-not-working/

This type of modal setting for a MsgBox can not have a time out in the message box command itself, it just won't work. This is a Windows issue and not an AutoIt one. I am changing this to a documentation issue for the help file rather than a bug, as it is not a bug, just a Windows limitation.

comment:2 Changed 6 years ago by TicketCleanup

  • Version set to Other

Automatic ticket cleanup.

comment:3 Changed 6 years ago by BrewManNH

  • Milestone set to 3.3.13.20
  • Owner set to BrewManNH
  • Resolution set to Fixed
  • Status changed from new to closed

Fixed by revision [11158] in version: 3.3.13.20

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The owner will remain BrewManNH.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.