Modify

Opened 5 years ago

Closed 5 years ago

#2975 closed Feature Request (No Bug)

_WinAPI_GetFontResourceInfo return only the first 31 characters from font name

Reported by: ffdshow Owned by:
Milestone: Component: AutoIt
Version: Severity: None
Keywords: Cc:

Description

I started to rename some fonts using their name retrieved by _WinAPI_GetFontResourceInfo function. The function returns only the first 31 characters (from the left to the right as I saw when I opened several fonts in Notepad2) and removed the space characters from names. Double clicking on fonts in Windows 8.1, seems to reveal the names with space characters included, but it's incomplete too.
I opened several fonts in Notepad2 and in generally, the font name is on the left of the word 'version'.
This is not a bug report, it's rather a feature request for a complete name of fonts.
Thanks!

Attachments (0)

Change History (6)

comment:1 Changed 5 years ago by TicketCleanup

  • Version 3.3.12.0 deleted

Automatic ticket cleanup.

comment:2 Changed 5 years ago by ffdshow

I just saw that Windows retrieve 31 characters for file name too.

comment:3 Changed 5 years ago by Jpm

The question is what is the undocumented or perhaps a documented one that can do the job

You may notice that this UDF is using an undocumented API ...

comment:4 Changed 5 years ago by Jpm

Checking again I don't see your problem as I can list such font
Just run the example from the help file
I get "Copperplate Gothic Bold Condensed BT" from COPGOTBC.TTF Under Windows8.1

comment:5 Changed 5 years ago by anonymous

It looks like I did a mistake. I downloaded COPGOTBC.TTF, because I didn't have it installed in Windows 8.1 and run the script, which return the full name of the font (37 characters). The problem was that all fonts I have don't have spaces in their internal full names and that gave me doubts regarding _WinAPI_GetFontResourceInfo function.
Thanks!

comment:6 Changed 5 years ago by Jpm

  • Resolution set to No Bug
  • Status changed from new to closed

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.