Modify

Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#2994 closed Bug (Wont Fix)

Can't run _Excel_RangeFind example in 3.3.13.19

Reported by: BrewManNH Owned by:
Milestone: Component: Standard UDFs
Version: 3.3.13.19 Severity: None
Keywords: Cc:

Description

When you try to run any of the example scripts, from the help file for _Excel_RangeFind, in 3.3.13.19 it errors out every time.

AutoIt3\Include\Excel.au3" (608) : ==> The requested action with this object has failed.:
$aResult[$iIndex][1] = $oMatch.Name.Name
$aResult[$iIndex][1] = $oMatch ERROR

This example runs fine in 3.3.12.0

Attachments (0)

Change History (2)

comment:1 Changed 4 years ago by water

  • Resolution set to Wont Fix
  • Status changed from new to closed

This is caused by the way AutoIt 3.3.13.19 handles COM errors.
Up to 3.3.12.0 a COM error was returned by setting @error, with 3.3.13.19 the script crashes when you haven't set up a COM error handler.

Up to 3.3.12.0 the script simply checked @error and then decided what to do. Now you need a COM error handler even when you wanted to ignore the error.
I hope this change will be thought over before the release of the next production version. Now it is a huge overhead with little to none advantage compared to the "old" solution.

The current Excel UDF in the repository has a COM error handler established for each function when called and dropped at the end.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.