Modify

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#300 closed Bug (No Bug)

to jon, "using CLASS and TEXT together..."

Reported by: anonymous Owned by:
Milestone: Component: AutoIt
Version: 3.2.12.0 Severity: None
Keywords: Cc:

Description

1.
http://img141.imageshack.us/img141/7534/classtextty3.png
I said it by au3info. This is what I mean.
and, It's working well up to 3.2.8.1

2."e.g. Click the 2nd instance of a "Button" control containing the text "Finish"
ControlClick("My Window", "", "[CLASS:Button; TEXT:Finish; INSTANCE:2]")"
wrote by you.

and you said,
"You want the FIRST instance of a "Button" class containing the text "&Move". OR the 10th instance of a "Button" class."

so, SECOND instance of a "Button" class containing the text "Finish"? it's your intention?
it's nonsense. you think there is two button that have the same
text "Finish"? if it is, how can I know it's instance number?
au3info only show instance of a button class.
au3 is not your private program that only you use,
you open it, then I think program must follow common sense.
for example, pic in 1.
If not, you must notify it in history log with reasonalble explanation about it.

3.sorry for my bad english.

Attachments (0)

Change History (2)

comment:1 Changed 12 years ago by Valik

  • Resolution set to No Bug
  • Status changed from new to closed

What the hell are you on about? See the Advanced (Class) line you circled a few things in? That's what you need to be using. Why do you want to specify the text *and* the instance? The properties are "AND" properties. Your code says "I want the 10th button and it's text should be &Move". What you want to say is "I want the 10th button" or "I want the first button with the text &Move". But that's not what your code says.

This is not a bug. You're being a retard even after having it explained to you.
And now you're being insulting to Jon by saying something that makes sense lacks sense just because you don't have the sense to understand how it works.

Closing.

comment:2 Changed 12 years ago by Jon

The Au3Info tool really is only setup to show Class and Instance parameters. When you move onto specifying _more_ than these paramters you need to start thinking by yourself because there is no way we can show all combinations. "Instance" always comes last and is the instance _if all the other parameters match_.

Yes two buttons may have the same text - they could be in different groups, or even hidden (many dialogs hide controls when going from page to page). That is _exactly_ why we wrote it this way. If you couldn't specify the button you wanted I could understand but you can. Class:Button; Text:&Move. I'm sorry for wanting to give people multiple ways to specify buttons suitable for different situations...

By all means suggest improvements for the documentation if it's misleading but don't keep telling me I am wrong when I wrote the code and it's working how I designed it.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.