Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#3053 closed Bug (Rejected)

Different file size after Encrypt-Decrypt file

Reported by: mvladb@… Owned by:
Milestone: Component: Standard UDFs
Version: 3.3.12.0 Severity: None
Keywords: Encrypt, decrypt, huge file intergrity, AES, 3DES Cc:

Description

Hello!
At the moment I'm having a problem with integrity of decrypted file.
First time I mean that it is my script fault and I'm try standart _Crypt_EncryptFile.au3 and _Crypt_decryptFile.au3 scripts for investigate a problem. Result are the same - different files size (and MD5/SHA1 checksum) after encrypting-decrypting. Try to use AES 128-256 and 3DES.
Original file is huge - 55.4 GB (59 579 039 744 bytes) binary file.
After encryption size is 55.4 GB (59 579 039 760 bytes)
After decryption 55.4 GB (59 579 039 748 bytes).
As you see decrypted file size is on 4 bytes larger then original, of course after that file is corrupted.
8-9 GB file successfully encrypted and decrypted.
OS: Windows 7 Pro SP1 x64

Attachments (0)

Change History (2)

comment:1 Changed 5 years ago by Jos

  • Resolution set to Rejected
  • Status changed from new to closed

This is not a bug report and really should be posted in the support forum.

Jos

comment:2 Changed 5 years ago by jchd18

Additional note: https://www.autoitscript.com/forum/topic/173380-different-file-size-after-encrypt-decrypt-file/?do=findComment&comment=1254439 comes with a test script which works as expected. So "works for me".

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.