Modify

Opened 2 years ago

Closed 2 years ago

Last modified 6 days ago

#3078 closed Bug (Completed)

bug in _ArrayUnique

Reported by: anonymous Owned by: Melba23
Milestone: 3.3.14.2 Component: Standard UDFs
Version: 3.3.14.0 Severity: None
Keywords: Cc:

Description

"C:\Program Files (x86)\AutoIt3\autoit-v3.3.14.0\Include\Array.au3" (2297) : ==> Array variable has incorrect number of subscripts or subscript dimension range exceeded.:
If IsInt($aArray[$iBase]) Then
If IsInt(^ ERROR
->21:48:19 AutoIt3.exe ended.rc:1

reproduser:

#include <Array.au3>

Local $aArray[2][3] = [[1,"",""],["aaa","bbb","ccc"]]
_ArrayDisplay($aArray)
Local $NewPatternArray = _ArrayUnique($aArray,2,1)

Attachments (2)

testData2.xlsx (8.9 KB) - added by jayme_fishman@… 2 years ago.
test data to reproduce a bug with _ArrayUnique
test.au3 (1.2 KB) - added by jayme_fishman@… 2 years ago.
test script to go with test data to reproduce possible bug with _ArrayUnique

Download all attachments as: .zip

Change History (12)

comment:1 Changed 2 years ago by guinness

I am not seeing the bug

Last edited 2 years ago by guinness (previous) (diff)

comment:2 Changed 2 years ago by guinness

  • Resolution set to No Bug
  • Status changed from new to closed

Please ensure you have upgraded the UDFs as well

comment:3 Changed 2 years ago by anonymous

Why?? I just have clean install of 3.3.14.0 and bug is still crush script... Or you saying UDFs is not updated in this process?

>"C:\Program Files (x86)\AutoIt3\SciTE\AutoIt3Wrapper\AutoIt3Wrapper.exe" /run /prod /ErrorStdOut /in "E:\Program Files\Auto-it scripts\test_507.au3" /UserParams    
+>19:23:23 Starting AutoIt3Wrapper v.15.503.1200.1 SciTE v.3.5.4.0   Keyboard:00000409  OS:WIN_XP/Service Pack 2  CPU:X64 OS:X64    Environment(Language:0409)
+>         SciTEDir => C:\Program Files (x86)\AutoIt3\SciTE   UserDir => C:\Documents and Settings\***\Local Settings\Application Data\AutoIt v3\SciTE\AutoIt3Wrapper   SCITE_USERHOME => C:\Documents and Settings\***\Local Settings\Application Data\AutoIt v3\SciTE 
>Running AU3Check (3.3.14.0)  from:C:\Program Files (x86)\AutoIt3  input:E:\Program Files\Auto-it scripts\test_507.au3
+>19:23:25 AU3Check ended.rc:0
>Running:(3.3.14.0):C:\Program Files (x86)\AutoIt3\autoit3.exe "E:\Program Files\Auto-it scripts\test_507.au3"    
--> Press Ctrl+Alt+Break to Restart or Ctrl+Break to Stop
"C:\Program Files (x86)\AutoIt3\Include\Array.au3" (2297) : ==> Array variable has incorrect number of subscripts or subscript dimension range exceeded.:
If IsInt($aArray[$iBase]) Then
If IsInt(^ ERROR
->19:23:28 AutoIt3.exe ended.rc:1
+>19:23:28 AutoIt3Wrapper Finished.
>Exit code: 1    Time: 5.577

comment:4 Changed 2 years ago by anonymous

As addition - problem is - my array is 2D, so string like

If IsInt($aArray[$iBase]) Then

immediately and reasonable cause error. Am I right?

comment:5 Changed 2 years ago by guinness

I am not able to reproduce it with the reproducer above, so I a, suggesting you ensure the array UDF has the same version number as to the AutoIt version.

Related: https://www.autoitscript.com/forum/topic/174055-_arrayunique-failing-for-some-reason

comment:6 Changed 2 years ago by guinness

  • Resolution No Bug deleted
  • Status changed from closed to reopened

comment:7 Changed 2 years ago by guinness

I stand corrected, sorry

comment:8 Changed 2 years ago by Melba23

  • Milestone set to 3.3.15.1
  • Owner set to Melba23
  • Resolution set to Completed
  • Status changed from reopened to closed

Changed by revision [11433] in version: 3.3.15.1

Changed 2 years ago by jayme_fishman@…

test data to reproduce a bug with _ArrayUnique

Changed 2 years ago by jayme_fishman@…

test script to go with test data to reproduce possible bug with _ArrayUnique

comment:9 Changed 2 years ago by guinness

  • Milestone changed from 3.3.15.1 to 3.3.14.2

comment:10 Changed 6 days ago by anonymous

ali.amini.1383.ali

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The owner will remain Melba23.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.