Modify

Opened 4 years ago

Closed 4 years ago

#3126 closed Bug (No Bug)

Drag&Drop not working on Windows 10

Reported by: anonymous Owned by:
Milestone: Component: AutoIt
Version: 3.3.14.0 Severity: None
Keywords: Drag, Drop, Event, Windows 10 Cc:

Description

The Drag&Drop Event is not working for Windows 10. On 8.1 it's working fine as well as on 7 but 10 doesn't.

There were no syntax or logical errors in several scripts I tried on the internet (even with evelated prigileges).

Attachments (0)

Change History (3)

comment:1 Changed 4 years ago by Jpm

please follow track submision guidelines.
at least a repro script is needed

For me I use the drag&drop Under Windows 10 without any problem

comment:2 Changed 4 years ago by anonymous

Any script doesn't work for me. It doesn't matter which I take.
It doesn't take the file into the input in 10 but in 8.1 it works fine.
Compability in 8 didn't work either.

#include <EditConstants.au3>
#include <GUIConstantsEx.au3>
#include <StaticConstants.au3>
#include <WindowsConstants.au3>

#Region ### START Koda GUI section ### Form=
$Form1 = GUICreate("Func Drag File and Drop", 256, 53, -1, -1,-1, $WS_EX_ACCEPTFILES)
GUISetOnEvent($GUI_EVENT_DROPPED, "Drag")
$Input1 = GUICtrlCreateInput("[ ... ]", 8, 24, 241, 21)
GUICtrlSetState(-1, $GUI_DROPACCEPTED)
$Label1 = GUICtrlCreateLabel("Arraste o arquivo e solte", 8, 8, 118, 16)
GUISetState(@SW_SHOW)
#EndRegion ### END Koda GUI section ###

Func Drag()
   ConsoleWrite("ID: "&@GUI_DRAGID & " File: "&@GUI_DRAGFILE &" Drop: "&@GUI_DROPID&@CRLF)
EndFunc

While 1
	$nMsg = GUIGetMsg()
	Switch $nMsg
		Case $GUI_EVENT_CLOSE
			Exit

	EndSwitch
WEnd

comment:3 Changed 4 years ago by BrewManNH

  • Resolution set to No Bug
  • Status changed from new to closed

I seriously doubt that script works fine in any OS version. Mainly because you're using GUISetOnEvent without using the autoit option turning on OnEvent mode. Also you can't use OnEvent mode and message mode in the same script at the same time. If you add the line to the script, the drop indication works, but the GUIGetMsg detection will fail.

Opt("GUIOnEventMode", 1)

This is not a bug, this is just not reading the manual.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.