Modify

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#315 closed Bug (No Bug)

GUICtrlSetOnEvent() doesn't work if there are too many controls on one form

Reported by: furroy@… Owned by:
Milestone: Component: AutoIt
Version: 3.2.12.0 Severity: None
Keywords: Cc:

Description

If the button isn't created & linked before other controls are, it won't call the event handler.

If you rearrange the order the controls are created, it will work if the button is at the top, but not at the bottom.

Attachments (1)

shitty.au3 (2.3 KB) - added by furroy@… 12 years ago.
Repro code & workaround

Download all attachments as: .zip

Change History (3)

Changed 12 years ago by furroy@…

Repro code & workaround

comment:1 Changed 12 years ago by Valik

  • Resolution set to No Bug
  • Status changed from new to closed

This is not a bug. Your label is too wide and it obscures the button. Clicks do not get through to the button. The simple answer is, don't overlap controls.

Closing as no bug.

comment:2 Changed 12 years ago by dammit

i feel like an idiot, lol. i was just about to come delete this ticket when i realized my mistake!

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.