Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#3170 closed Bug (No Bug)

IniRead() functions returns ANSI chars instead of Unicode Chars

Reported by: Factfinder Owned by:
Milestone: Component: AutoIt
Version: 3.3.14.2 Severity: None
Keywords: Cc:

Description

IniRead() function works good for ANSI strings but returns ANSI chars instead of Unicode Chars if the data string contains Unicode chars.

Attachments (1)

extensions.ini (367 bytes) - added by anonymous 4 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 4 years ago by mLipok

Please attach any INI file with this issue.

comment:2 Changed 4 years ago by Jpm

Please add a repro script/ Os Version as suggested by Track report submission

comment:3 Changed 4 years ago by BrewManNH

INI files by design are not Unicode compatible. There are workarounds to get them to be able to utilize Unicode characters, but it's non-standard to use them with Unicode characters.

They are from the ancient days of Windows 3, maybe even Windows 1, and up, you should be using XML files, the registry, or some other functionality for Unicode compatibility.

Read more here.
http://blogs.msdn.com/b/oldnewthing/archive/2007/11/26/6523907.aspx

comment:4 Changed 4 years ago by guinness

  • Resolution set to No Bug
  • Status changed from new to closed

This is not a bug. Search the Forum please.

Changed 4 years ago by anonymous

comment:5 Changed 4 years ago by anonymous

I'm not creating an ini file. I try to read an existed ini. Firefox is using an extensions.ini file that contains a list of add-ons. The add-ons are placed in the user home path and in some cases the user name (like in East Europian names) contains Unicode chars. Example of the content of extensions.ini:

[ExtensionDirs]
Extension0=C:\Documents and Settings\Właściciel\Dane aplikacji\Mozilla\Firefox\Profiles\1th1xarp.default-1438872568250\extensions\translator@zoli.bod.xpi

[ThemeDirs]
Extension0=C:\Program Files\Mozilla Firefox\browser\extensions\{972ce4c6-7e08-4474-a285-3208198ce6fd}

[MultiprocessIncompatibleExtensions]
Extension0=translator@zoli.bod

The file is attached too.

comment:6 Changed 4 years ago by anonymous

Having said that I don't need the function and have found a workaround and don't use the function any more. I thought I would report it for the record. Should the developers find it not needed to adjust the function, they may just leave this ticket where it is now.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.