Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#3203 closed Bug (No Bug)

IE - Variable contents are lost when navigating to any page

Reported by: mexykanu Owned by:
Milestone: Component: AutoIt
Version: 3.3.14.2 Severity: None
Keywords: _ie, ie Cc:

Description

Hello,

We have the folowing code:

Global $oIE = _IEAttach("your website","url")

local $body1 = _IETagNameGetCollection($oie,'body',0)
MsgBox(0,'',$body1.innerhtml)
_IENavigate($oie,'any page')
MsgBox(0,'',$body1.innerhtml)

This code attaches to a IE window, loads the <body> tag in a variable and navigates to a different page.

Issue: After navigating to a different page, the contents of the variable are no longer accessible or are lost. This issue has been around for a long time, it has not been fixed in the latest version.
This can be reproduced with any website.

It is a very severe issue since variable contents should only be changed by the user.

Attachments (0)

Change History (3)

comment:1 Changed 4 years ago by mLipok

This is not AutoIt or UDF bug.
This is not support forum.

Ask here:
https://www.autoitscript.com/forum/forum/2-autoit-general-help-and-support/

comment:2 Changed 4 years ago by mLipok

  • Resolution set to No Bug
  • Status changed from new to closed

comment:3 Changed 4 years ago by mexykanu

OK, But what is an autoit bug then ?!

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.