Modify

Opened 4 years ago

Closed 4 years ago

#3207 closed Bug (No Bug)

_GUICtrlListView_AddArray Error when add single dimension array

Reported by: damien2008 (a) mail.ru Owned by:
Milestone: Component: AutoIt
Version: 3.3.14.2 Severity: None
Keywords: Cc:

Description

A bug was find, whet trying to add array to ListView.
seems, that error present in earlie versions too.

when try to add 1-dimension array, it falls in error (of array dimension)
version: 3.3.14.2
file: GuiListView.au3
line: 428, DllStructSetData($tBuffer, "Text", $aItems[$iI][0])

the correct DllStructSetData($tBuffer, "Text", $aItems[$iI]);[0]) <---

when add 2-dimension array, it works fine.

solution:
seems, it must be added an check for array dimension before process adding items.

Br. damien2008
autoit-script.ru (russian-speak community), Ukraine.
http://autoit-script.ru/index.php?action=profile;u=513
email: damien2008 (a) mail.ru

Attachments (0)

Change History (1)

comment:1 Changed 4 years ago by Jpm

  • Resolution set to No Bug
  • Status changed from new to closed

As stated in the doc the Array as to be 2D
So it is not a bug

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.