Modify

Opened 4 years ago

Closed 7 weeks ago

Last modified 7 weeks ago

#3246 closed Bug (Fixed)

_IENavigate not working redirect on IE 11/Win 10

Reported by: error@… Owned by: mLipok
Milestone: 3.3.15.4 Component: Standard UDFs
Version: 3.3.15.0 Severity: None
Keywords: IE, redirect Cc:

Description

Testscript:

#Region    ;************ Includes ************
#Include <IE.au3>
#EndRegion ;************ Includes ************
$oIE = _IECreate("",1)
_IENavigate($oIE, "http://www.hs-karlsruhe.de/rss/hska-feed.xml.html")

Error and Scriptfreeze:

--> IE.au3 T3.0-2 Warning from function _IEAttach, $_IESTATUS_NoMatch

Additional information:

  • Error only with Win 10 and IE 11.
  • Only Website with redirect to other Sites.
  • In the Beta 3.3.15.0, the problem also exists

Attachments (0)

Change History (8)

comment:1 Changed 4 years ago by mLipok

You should ask on the forum in first place.


So please:
Open it and wait for responses.

This ticket I stay as is for a while.

comment:2 Changed 4 years ago by Jpm

  • Resolution set to No Bug
  • Status changed from new to closed

I don'tsee the problem as the display is the same if you use your "http" directly Under IE11
Edge is displaying Something different I don't know who is the correct behavior

comment:3 Changed 4 years ago by Jpm

  • Resolution No Bug deleted
  • Status changed from closed to reopened

I reopen as the page is well displayed but the script does end (Thx mlipok)

comment:4 Changed 4 years ago by mLipok

The problem is with _IELoadWait().

Check this example with and without commented _IELoadWait() :

#include <IE.au3>
_Example()
Func _Example()
    Local $oIE = _IECreate()
    ConsoleWrite(@ScriptLineNumber & @CRLF)
    _IENavigate($oIE, "http://www.hs-karlsruhe.de/rss/hska-feed.xml.html", 0)
    ConsoleWrite(@ScriptLineNumber & @CRLF)
;~ _IELoadWait($oIE)
    ConsoleWrite(@ScriptLineNumber & @CRLF)

    ; temporary workaround
    Local $oDocument = _IEDocGetObj($oIE)
    Local $vReadyState1
    While Sleep(10)
        $vReadyState1 = $oDocument.readyState
        If @error then Return SetError(@error, @extended, -1)
        If (String($vReadyState1) = "complete" Or $vReadyState1 = 4) Then
            Return $_IESTATUS_Success
        EndIf
    WEnd


EndFunc   ;==>_Example

Please confirm that this code is working for you in any other cases.
If all is OK then you can use this as temp workaround.


btw.
I have this solved with my IE Rewrited UDF.
Unfortunately, I got stuck on the creation of documentation to this UDF.
So I'm far from publishing stage.

comment:5 Changed 3 years ago by mLipok

  • Component changed from AutoIt to Standard UDFs
  • Owner set to mLipok
  • Status changed from reopened to assigned
  • Version changed from 3.3.14.0 to 3.3.15.0

comment:6 Changed 2 years ago by Jpm

@mLipok
perhaps you can speed up the rewriting ...

comment:7 Changed 7 weeks ago by mLipok

  • Milestone set to 3.3.15.4
  • Resolution set to Fixed
  • Status changed from assigned to closed

Fixed by revision [12334] in version: 3.3.15.4

comment:8 Changed 7 weeks ago by mLipok

Trying Attach should not be possible when you not specify any URL.

Fixed

If $iTryAttach Then

by this simply modification:

If $iTryAttach And $sUrl <> "" Then

after this MOD

There is no:

--> IE.au3 T3.0-2 Warning from function _IEAttach, $_IESTATUS_NoMatch

btw.
This testing URL site provided by OP , currently navigates to:
https://www.hs-karlsruhe.de/error/404.html

Last edited 7 weeks ago by mLipok (previous) (diff)

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The owner will remain mLipok.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.