Modify

Opened 11 years ago

Closed 11 years ago

#350 closed Feature Request (Rejected)

FileInstall fails when user login name is non-English chars

Reported by: ehaerim@… Owned by: Jon
Milestone: Component: AutoIt
Version: Severity: None
Keywords: Cc:

Description

$execdir = "C:\HelpDesk\"
FileInstall("winvnc.exe", $execdir, 1)
Run($execdir & "winvnc.exe " & " -connect " & $RemoteHelperIP & ":5500 -noregistry", $execdir)

Above code succeeds in most cases but fails when the user's login name is in non-English(for example, Korean). The 'Run' function fails in finding the target file.

This bug should be tested under the following conditions to reproduce:

  • non-English Windows (I am not 100% sure, though)
  • user login name is in non-English (ex)영업

It seems that 'FileInstall' does not handle properly MBCS chars in the file path, but it's just my guess.

Please find the cause of this bug and fix ASAP.

Thanks.

Attachments (0)

Change History (6)

comment:1 in reply to: ↑ description Changed 11 years ago by Valik

Replying to ehaerim@gmail.com:

Please find the cause of this bug and fix ASAP.

Or what? Really, that's a very rude thing to say. You are in no place to request prioritization of our time and effort to fix bugs. We'll fix it when we fix it like we do with everything else.

comment:2 Changed 11 years ago by Jpm

can you check fileinstall return I suspect the "winvnc.exe" is not found so fileinstall does work due to unable to found the file. Nothing to do with the user.
Your example is not MBCS at least under a non asian windows.

comment:3 follow-up: Changed 11 years ago by Jon

  • Owner set to Jon
  • Status changed from new to accepted
  • Type changed from Bug to Feature Request

Some of the internal FileInstall code works in ANSI (converts from Unicode) and this may cause problems here. I'll update the code in a future version. Changing to feature request so I can track it better.

comment:4 Changed 11 years ago by TicketCleanup

  • Version 3.2.12.0 deleted

Automatic ticket cleanup.

comment:5 in reply to: ↑ 3 Changed 11 years ago by anonymous

Replying to Jon:

Some of the internal FileInstall code works in ANSI (converts from Unicode) and this may cause problems here. I'll update the code in a future version. Changing to feature request so I can track it better.

Yes please check and fix this problem. FileInstall always seems to fail when the path includes Asian characters. I know this happens at least for Korean, Japanese, and Chinese.

Do I need to add this issue to feature request myself or is it already added there?

I wish I can be emailed when this issue is resolved.

Thanks.

HaeRim Lee

comment:6 Changed 11 years ago by Valik

  • Resolution set to Rejected
  • Status changed from accepted to closed

We can't find anything wrong in our code and we can't reproduce it. We apparently already changed the code Jon had in mind so closing.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The owner will remain Jon.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.