Modify

Opened 4 years ago

Closed 4 years ago

#3523 closed Bug (No Bug)

Can't access array with _WM_COMMAND

Reported by: jamestran201@… Owned by:
Milestone: Component: Other
Version: 3.3.14.2 Severity: None
Keywords: Cc:

Description

I have a complete error with array when i'm clicked in button, array error ( can't use _ArrayDiplay() )

All function return an array will same be error, autoit crash with msgbox

#include <Array.au3>
#include <WindowsConstants.au3>
#include <GUIConstantsEx.au3>

$hGUI = GUICreate("Window", 500, 400, -1, -1)
$hButton = GUICtrlCreateButton("CRASH!", 126, 103, 278, 129)
GUICtrlSetFont(-1, 20, 800, 0)
GUISetState()

GUIRegisterMsg($WM_COMMAND, "_WM_COMMAND")

While 1
	$hMsg = GUIGetMsg()
	Switch $hMsg
		Case -3
			Exit
	EndSwitch
WEnd

Func _WM_COMMAND($hWnd, $Msg, $wparam, $lparam)
If BitAND($wparam, 0x0000FFFF) = $hButton Then

	EndIf

	Dim $a = [1,2,3,4,5,6]
	_ArrayDisplay($a)

	Return $GUI_RUNDEFMSG
EndFunc   ;==>_WM_COMMAND

Attachments (0)

Change History (1)

comment:1 Changed 4 years ago by Melba23

  • Resolution set to No Bug
  • Status changed from new to closed

Not a bug - just do not use blocking functions within a handler, as is explained in the Help file.

And in future, please use the forum for support - not Trac.

M23

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.