Modify

Opened 4 years ago

Closed 12 months ago

#3573 closed Bug (Works For Me)

Unable to use backspace in GUI-controls with embedded IE object

Reported by: anonymous Owned by:
Milestone: Component: AutoIt
Version: 3.3.14.2 Severity: None
Keywords: Cc:

Description

Basically, the focus is not working properly when embedding COM objects.

Backspace + tab will be triggered on the COM-object control instead of the focused gui

Reproduce

Opt("GUIOnEventMode", 1)
#include <IE.au3>
#include <GUIConstantsEx.au3>


SplashTextOn("Please wait", "Please wait for setup", 200, 50)
Global $oIE = _IECreateEmbedded()
Global $hGUI = GUICreate("", 800, 600)
; Create controls
Global $iMenu = GUICtrlCreateMenu("Test")
Global $iOpenNewGui = GUICtrlCreateMenuItem("Open new gui", $iMenu)
Global $iObj = GUICtrlCreateObj($oIE, 0, 0, 800, 600)

; Show gui
GUISetState()

; Navigate to test
_IENavigate($oIE, "https://pastebin.com/AL8kXcNB")

; Go to inputarea
Local $oTextarea = _IEGetObjById($oIE, "paste_code")
_IEAction($oTextarea, "focus")
Send("{end}")

SplashOff()
MsgBox(0,"How to reproduce ", "1. Open Test -> Open new gui" & @LF & "2. Start typing" & @LF & "3. Start using backspace")
; Bind events
GUICtrlSetOnEvent($iOpenNewGui, Callback_OpenNewGui)
GUISetOnEvent($GUI_EVENT_CLOSE, "_exit")


while IsHWnd($hGUI)

WEnd

Func _Exit()
    GUIDelete(@GUI_WinHandle)
EndFunc

Func Callback_OpenNewGui()
    Local $hGUI = GUICreate("", 150, 150)
    ; Create controls
    GUICtrlCreateInput("",25, 10, 100)
    ; Bind events
    GUISetOnEvent($GUI_EVENT_CLOSE, "_exit")
    ;Show gui
    GUISetState()
EndFunc

Attachments (0)

Change History (1)

comment:1 Changed 12 months ago by Jpm

  • Resolution set to Works For Me
  • Status changed from new to closed

Hi,
I recheck with the latest Windows 2004, latest AutoIt 3.3.14.5 and it works for me.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.