Modify

Opened 2 years ago

Closed 23 months ago

#3576 closed Feature Request (Rejected)

_PathSplit

Reported by: Loran A. Rendel <loran@…> Owned by:
Milestone: Component: Standard UDFs
Version: Severity: None
Keywords: Cc:

Description (last modified by BrewManNH)

Function _PathSplit now returns an array with parameters, but also requires to fill all byref args: $sDir, $sFileName, $sExtension.

If I need only the filename or need output array only I also must use dummy byref arguments.

So it will be better if there will be no arguments except input string, and result will be returned as array.

Attachments (0)

Change History (5)

comment:1 follow-up: Changed 2 years ago by Melba23

_PathMake returns a string. Are you thinking of _PathSplit?

If so, then this is a duplicate of https://www.autoitscript.com/trac/autoit/ticket/3540

M23

comment:2 in reply to: ↑ 1 Changed 2 years ago by Loran A. Rendel <loran@…>

Replying to Melba23:

_PathMake returns a string. Are you thinking of _PathSplit?

If so, then this is a duplicate of https://www.autoitscript.com/trac/autoit/ticket/3540

M23

Oh, right, I have mistyped the function's name.

comment:3 Changed 2 years ago by Loran A. Rendel <loran@…>

However, it's not the full duplicate, because my suggestion could be done with no relation to Byref functionality.

comment:4 Changed 2 years ago by BrewManNH

  • Description modified (diff)
  • Summary changed from _PathMake to _PathSplit

comment:5 Changed 23 months ago by Jpm

  • Resolution set to Rejected
  • Status changed from new to closed

I think the Melba23 is a good remark (byRef optional)as we don't want to do a regression on the functions
Not sure Jon want or can implement it

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.