Modify

#3618 closed Bug (Fixed)

x86 or x64 for $tagNMTVKEYDOWN pb align

Reported by: gilles@… Owned by: Jpm
Milestone: 3.3.15.1 Component: AutoIt
Version: 3.3.14.4 Severity: None
Keywords: Cc:

Description

when processing $TVN_KEYDOWN notification the structure $tagNMTVKEYDOWN does not properly set vKey under x64.

When changing $tagNMTVKEYDOWN definition, it is ok for both architecture, but Flags has an incorrect value on x86 architetcure.
As the documentatio state that it is always 0, it should not be a problem, but I wasn't able to find how to fix it.

So change tagNMTVKEYDOWN
from

Global Const $tagNMTVKEYDOWN = "align 1;" & $tagNMHDR & ";word VKey;uint Flags"

to

Global Const $tagNMTVKEYDOWN = $tagNMHDR & ";word VKey;uint Flags"

For example to reproduce see https://www.autoitscript.com/forum/topic/192326-an-event-for-treeview-checkbox-check/

It feels like equivalent to https://www.autoitscript.com/trac/autoit/ticket/1510 or https://www.autoitscript.com/trac/autoit/ticket/1479 or https://www.autoitscript.com/trac/autoit/ticket/1130

Attachments (0)

Change History (2)

comment:1 Changed 21 months ago by Jpm

State = 0 is what is described in the MSDN doc !!!
anyway you right the align as never be updated since the introduction of the struct/endstruc which is now taking in account the alignment x86/x64
Thanks for the ticket

comment:2 Changed 21 months ago by Jpm

  • Milestone set to 3.3.15.1
  • Owner set to Jpm
  • Resolution set to Fixed
  • Status changed from new to closed

Fixed by revision [12081] in version: 3.3.15.1

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The owner will remain Jpm.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.