Modify

Opened 12 years ago

Closed 12 years ago

#364 closed Bug (No Bug)

Error at runtime caused by obfuscator

Reported by: madflame991 Owned by: Jos
Milestone: Component: SciTE4AutoIt
Version: Other Severity: None
Keywords: obfuscator Cc:

Description

After I compile this I get "Line -1: Error: Array variable subscript badly formatted". Why? I tested it on WinXP Pro Sp 1 and it worked, but on WInXP Pro SP2 it crushed.
The script has been compiled under version 3.2.12.0 and obfuscated under version 1.0.24.12

#Region ;**** Directives created by AutoIt3Wrapper_GUI ****
#AutoIt3Wrapper_UseUpx=n
#AutoIt3Wrapper_Run_Obfuscator=y
#EndRegion ;**** Directives created by AutoIt3Wrapper_GUI ****
Global $var[4]
$var[1] = 'boo'
MsgBox(0, 'title', $var[1])

Attachments (1)

err_obf.JPG (36.1 KB) - added by madfame991 12 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 12 years ago by TicketCleanup

  • Severity changed from Blocking to None

Automatic ticket cleanup.

comment:2 Changed 12 years ago by Valik

  • Component changed from AutoIt to Other
  • Version changed from 3.2.12.0 to Other

comment:3 Changed 12 years ago by Jos

Works fine for me using the latest version of Obfuscator v1.0.24.17.

Jos

comment:4 Changed 12 years ago by Jos

  • Component changed from Other to SciTE4AutoIt
  • Owner set to Jos
  • Status changed from new to assigned

Changed 12 years ago by madfame991

comment:5 Changed 12 years ago by madflame991

I downloaded the last version and it still won't work. The error only appears when I'm launching the compiled executable under Windows XP SP2. I provided a screenshot in the attachement.

comment:6 Changed 12 years ago by Jos

Please zip up the following files and PM/Email them to me to allow me to see what is happening:

  • Original script source.
  • The Obfusticated version of the script
  • The Obfuscator.log generated by Obfuscator for this script located on the Obfuscator program directory.
  • The ouput EXE giving the error.

Jos

comment:7 Changed 12 years ago by Valik

  • Summary changed from Error at runime caused by obfuscator to Error at runtime caused by obfuscator

comment:8 Changed 12 years ago by Jos

  • Resolution set to No Bug
  • Status changed from assigned to closed

Received the test files and they all worked fine for me on WinXP sp2 & 3.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The owner will remain Jos.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.