Modify

Opened 2 years ago

Closed 3 months ago

#3653 closed Feature Request (Rejected)

Can't set value of element of nested array

Reported by: gf16954@… Owned by:
Milestone: Component: AutoIt
Version: Severity: None
Keywords: Cc: gf16954@…

Description

Local $b[2]
Local $c[2]
$c[0]=1
$b[0]=$c
ConsoleWrite(($b[0])[0] & @CRLF) ; 1
($b[0])[0]=2
ConsoleWrite(($b[0])[0] & @CRLF) ; 1 !!!

; Workaround
Func Y(byRef $a, $i, $b)
	$a[$i]=$b
EndFunc

Y($b[0],0,2)
ConsoleWrite(($b[0])[0] & @CRLF) ; 2

Attachments (0)

Change History (4)

comment:1 Changed 2 years ago by Melba23

  • Type changed from Bug to Feature Request

comment:2 Changed 2 years ago by Melba23

Quote/

Think about your feature request. If you can do it via UDFs, then don't ask for it to be built in. There's a reason you can create your own functions.

/Quote

Certainly not a bug, but if it is a simple fix it might be worth the Devs looking at it. Otherwise just use your workaround as the above quote from the Trac lead-in page mentions.

M23

comment:3 Changed 2 years ago by TicketCleanup

  • Version 3.3.14.0 deleted

Automatic ticket cleanup.

comment:4 Changed 3 months ago by Melba23

  • Resolution set to Rejected
  • Status changed from new to closed

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.