Modify

Opened 2 years ago

Closed 10 months ago

#3718 closed Bug (No Bug)

AU3_ControlSend of AutoItX3_x64.dll doesn't work properly

Reported by: k.schaefer@… Owned by: mvptest
Milestone: Component: AutoItX
Version: 3.3.14.0 Severity: None
Keywords: AU3_ControlSend Cc:

Description

Hi,
I read a lot on your page about autoit and how to use it. In my code I use the .dll of autoit to perform some automization. Unfortunately if I use the AU3_ControlSend function which should send some keystrokes to a specific window, it just only send keystrokes to the current active window even tough I send the right windowhandle.
I tested it with the command AU3_WinCloseByHandle and sended the handle and it closed like exepected the right not active window. The function to get the window handle get only called once, I debugged the function and it never get called again after initialization.

My code around it looks like:
AU3_ControlSend(s_handle, nullptr, L"{DOWN}");
As I read before, I don't need to specify a control handle to perform the call properly and the mode is in default 0.

Attachments (0)

Change History (4)

comment:1 Changed 14 months ago by Jpm

  • Component changed from AutoIt to AutoItX
  • Owner set to Jon
  • Status changed from new to assigned

comment:2 Changed 12 months ago by Jpm

In fact looking at your ticket
the pb seems to come from a missing parameter in your call

AU3_ControlSend(s_handle, nullptr, nullptr, L"{DOWN}");

comment:3 Changed 12 months ago by Jpm

  • Owner changed from Jon to mvptest

comment:4 Changed 10 months ago by Jpm

  • Resolution set to No Bug
  • Status changed from assigned to closed

No confirmation so I close the ticket.
Just reopen a new one if still true with the script to reproduce

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The owner will remain mvptest.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.