Modify

Opened 6 weeks ago

Closed 5 weeks ago

#3779 closed Bug (Fixed)

AutoIt crashes

Reported by: anonymous Owned by:
Milestone: Component: AutoIt
Version: 3.3.14.5 Severity: None
Keywords: Cc:

Description

The newest version of AutoIt has problem controlling Internet Explorer through COM objects and crashes. I have to sometimes switch back to version 3.3.12.0, because in that version it doesn't crash. This is confirmed not only in my computer. Overall I use Internet Explorer only for simple tasks because controlling it is unpredictable. Another issue I have is Excel in which when there is low available memory the AutoIt crashes, but the Excel and the system still works.

Attachments (0)

Change History (6)

comment:1 Changed 6 weeks ago by Jpm

You must follow the ticket submission , no repro script = automatic closing

comment:2 Changed 6 weeks ago by anonymous

I don't know if I'll be able to post script but for example when I write the same html code in a loop to Internet Explorer document with open() write() close() the AutoIt after few iterations crashes or throws COM error 'Bad variable type' when writing to document. But if I switch to AutoIt 3.3.12.0 it works.

comment:3 Changed 6 weeks ago by mLipok

Please ask on the forum.
It is quite possible that I answer to your problem.

comment:4 Changed 6 weeks ago by Jpm

I will wait a while what you can get from the forum before I close the ticket.
I don't have a cristal ball to analyse your ticket.

comment:5 Changed 5 weeks ago by anonymous

I tried with the beta 3.3.15.3 and it works, so looks like this has been somehow fixed. It works also with the x64 version of the autoit 3.3.14.5. So you can close this ticket.

comment:6 Changed 5 weeks ago by Jpm

  • Resolution set to Fixed
  • Status changed from new to closed

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.