Modify

Opened 6 months ago

Closed 6 months ago

Last modified 6 months ago

#3860 closed Bug (No Bug)

Declared var not detected

Reported by: KaFu Owned by:
Milestone: Component: Standard UDFs
Version: 3.3.15.4 Severity: None
Keywords: Cc:

Description

#include <WinAPIInternals.au3>
MsgBox(0,"",$WINVER)

AU3Check 3.3.15.4 returns "$WINVER: possibly used before declaration." for this code, prod doesn't.

Attachments (0)

Change History (8)

comment:1 Changed 6 months ago by Jos

AU3Check 3.3.14.5 returns the exact same error for me... which version are you running with production?

>Running AU3Check (3.3.14.5)  from:C:\Program Files (x86)\AutoIt3  input:D:\Development\AutoIt3\programs\test\a.au3
"D:\Development\AutoIt3\programs\test\b\a.au3"(2,20) : warning: $WINVER: possibly used before declaration.
MsgBox(0,"",$WINVER)
~~~~~~~~~~~~~~~~~~~^

Jos

Last edited 6 months ago by Jos (previous) (diff)

comment:2 follow-up: Changed 6 months ago by anonymous

Jos, you didn't use the correct token. $__WINVER

comment:3 Changed 6 months ago by anonymous

the variable is removed on the newest beta build

comment:4 in reply to: ↑ 2 Changed 6 months ago by Jos

Replying to anonymous:

Jos, you didn't use the correct token. $__WINVER

i did use what was posted as issue so not sure why you responded like this ....right? ;)

comment:5 Changed 6 months ago by KaFu

It’s indeed

$__WINVER

Tracs validator seems to eat the underscores, sorry for not realizing.
Currently traveling, so mit sure about the latest prod version, but should be latest one.

comment:6 Changed 6 months ago by KaFu

Ah, var removed in Beta? Have to check that.

comment:7 Changed 6 months ago by Jos

  • Component changed from Au3Check to Standard UDFs
  • Resolution set to No Bug
  • Status changed from new to closed

Ok understand.
So looks like the INTERNAL variable is removed from Beta, so you need to set it yourself using _WinAPI_GetVersion()

Jos

comment:8 Changed 6 months ago by KaFu

Yep, confirmed, the INTERNAL variable was removed from Beta, so NO BUG.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.