Modify

Opened 5 months ago

Closed 4 months ago

Last modified 4 months ago

#3883 closed Bug (Fixed)

_DebugArrayDisplay produces uncalled console message

Reported by: jchd18 Owned by: Jon
Milestone: 3.3.16.1 Component: Standard UDFs
Version: 3.3.16.0 Severity: None
Keywords: Cc:

Description

This function invokes ArrayDisplay_Share (from ArrayDisplayInternals.au3) which defaults with its parameter $bDebug = True.

This causes a spurious console message like this:
Sorting all indexes = 0.4333

Attachments (0)

Change History (4)

comment:1 Changed 5 months ago by Jpm

It is not a bug but a way to understand if the new way of sorting is working well
the _ArrayDisplay() is not affected only the _DebugArrayDisplay()

comment:2 Changed 5 months ago by jchd18

Not a bug but a misfeature: it messes with the console output, without that spurious message being neither required, informative to the user nor called for.

I understand it may have been necessary while debugging the UDF but it's now parasitic in a release version.

comment:3 Changed 4 months ago by Jpm

  • Milestone set to 3.3.15.6
  • Owner set to Jpm
  • Resolution set to Fixed
  • Status changed from new to closed

Fixed by revision [12716] in version: 3.3.15.6

comment:4 Changed 4 months ago by Jon

  • Milestone changed from 3.3.15.6 to 3.3.16.1
  • Owner changed from Jpm to Jon

Fixed by revision [12717] in version: 3.3.16.1

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The owner will remain Jon.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.