Modify

Opened 3 months ago

Closed 3 months ago

#3898 closed Bug (No Bug)

Wrong references in au3.api

Reported by: Jos Owned by:
Milestone: Component: AutoIt
Version: 3.3.14.0 Severity: None
Keywords: Cc:

Description (last modified by Jos)

This is a list that contains a reference to the wrong include files, I came across while testing the dynamic autocomplete, in their "trunk\docs\autoit\english\txt2htm\txtlibfunctions" doc file which somebody needs to look at and correct:

! Func:	_WinAPI_BitBlt                	 Real Include:WinAPIGdiInternals.au3	 API Include:WinAPIGdi.au3
! Func:	_WinAPI_CombineRgn            	 Real Include:WinAPIGdiInternals.au3	 API Include:WinAPIGdi.au3
! Func:	_WinAPI_CopyBitmap            	 Real Include:WinAPIGdiInternals.au3	 API Include:WinAPIGdi.au3
! Func:	_WinAPI_CopyImage             	 Real Include:WinAPIGdiInternals.au3	 API Include:WinAPIGdi.au3
! Func:	_WinAPI_CreateANDBitmap       	 Real Include:WinAPIGdiInternals.au3	 API Include:WinAPIGdi.au3
! Func:	_WinAPI_CreateBitmap          	 Real Include:WinAPIGdiInternals.au3	 API Include:WinAPIGdi.au3
! Func:	_WinAPI_CreateCompatibleBitmap	 Real Include:WinAPIGdiInternals.au3	 API Include:WinAPIGdi.au3
! Func:	_WinAPI_CreateDIB             	 Real Include:WinAPIGdiInternals.au3	 API Include:WinAPIGdi.au3
! Func:	_WinAPI_CreateDIBColorTable   	 Real Include:WinAPIGdiInternals.au3	 API Include:WinAPIGdi.au3
! Func:	_WinAPI_CreateDIBSection      	 Real Include:WinAPIGdiInternals.au3	 API Include:WinAPIGdi.au3
! Func:	_WinAPI_CreateFile            	 Real Include:WinAPIInternals.au3	 API Include:WinAPIFiles.au3
! Func:	_WinAPI_CreateFont            	 Real Include:WinAPIGdiInternals.au3	 API Include:WinAPIGdi.au3
! Func:	_WinAPI_CreateFontIndirect    	 Real Include:WinAPIGdiInternals.au3	 API Include:WinAPIGdi.au3
! Func:	_WinAPI_CreateRectRgn         	 Real Include:WinAPIGdiInternals.au3	 API Include:WinAPIGdi.au3
! Func:	_WinAPI_CreateRoundRectRgn    	 Real Include:WinAPIGdiInternals.au3	 API Include:WinAPIGdi.au3
! Func:	_WinAPI_CreateSolidBrush      	 Real Include:WinAPIGdiInternals.au3	 API Include:WinAPIGdi.au3
! Func:	_WinAPI_CreateWindowEx        	 Real Include:WinAPISysInternals.au3	 API Include:WinAPISysWin.au3
! Func:	_WinAPI_DestroyWindow         	 Real Include:WinAPISysInternals.au3	 API Include:WinAPISysWin.au3
! Func:	_WinAPI_EnableWindow          	 Real Include:WinAPISysInternals.au3	 API Include:WinAPISys.au3
! Func:	_WinAPI_EnumWindows           	 Real Include:WinAPISysInternals.au3	 API Include:WinAPISysWin.au3
! Func:	_WinAPI_EnumWindowsPopup      	 Real Include:WinAPISysInternals.au3	 API Include:WinAPISysWin.au3
! Func:	_WinAPI_EnumWindowsTop        	 Real Include:WinAPISysInternals.au3	 API Include:WinAPISysWin.au3
! Func:	_WinAPI_FreeLibrary           	 Real Include:WinAPIInternals.au3	 API Include:WinAPIRes.au3
! Func:	_WinAPI_GetBitmapDimension    	 Real Include:WinAPIGdiInternals.au3	 API Include:WinAPIGdi.au3
! Func:	_WinAPI_GetClassName          	 Real Include:WinAPISysInternals.au3	 API Include:WinAPISysWin.au3
! Func:	_WinAPI_GetClientRect         	 Real Include:WinAPISysInternals.au3	 API Include:WinAPISysWin.au3
! Func:	_WinAPI_GetCursorInfo         	 Real Include:WinAPIInternals.au3	 API Include:WinAPIRes.au3
! Func:	_WinAPI_GetDesktopWindow      	 Real Include:WinAPISysInternals.au3	 API Include:WinAPISysWin.au3
! Func:	_WinAPI_GetDlgCtrlID          	 Real Include:WinAPIInternals.au3	 API Include:WinAPIDlg.au3
! Func:	_WinAPI_GetFocus              	 Real Include:WinAPISysInternals.au3	 API Include:WinAPISysWin.au3
! Func:	_WinAPI_GetModuleHandle       	 Real Include:WinAPIInternals.au3	 API Include:WinAPISys.au3
! Func:	_WinAPI_GetParent             	 Real Include:WinAPISysInternals.au3	 API Include:WinAPISysWin.au3
! Func:	_WinAPI_GetString             	 Real Include:WinAPIInternals.au3	 API Include:WinAPIMisc.au3
! Func:	_WinAPI_GetSysColor           	 Real Include:WinAPISysInternals.au3	 API Include:WinAPISysWin.au3
! Func:	_WinAPI_GetSysColorBrush      	 Real Include:WinAPIGdiInternals.au3	 API Include:WinAPIGdi.au3
! Func:	_WinAPI_GetSystemMetrics      	 Real Include:WinAPISysInternals.au3	 API Include:WinAPISys.au3
! Func:	_WinAPI_GetTextExtentPoint32  	 Real Include:WinAPIGdiInternals.au3	 API Include:WinAPIGdi.au3
! Func:	_WinAPI_GetTextMetrics        	 Real Include:WinAPIGdiInternals.au3	 API Include:WinAPIGdi.au3
! Func:	_WinAPI_GetVersion            	 Real Include:WinAPIInternals.au3	 API Include:WinAPISys.au3
! Func:	_WinAPI_GetWindow             	 Real Include:WinAPISysInternals.au3	 API Include:WinAPISysWin.au3
! Func:	_WinAPI_GetWindowHeight       	 Real Include:WinAPISysInternals.au3	 API Include:WinAPISysWin.au3
! Func:	_WinAPI_GetWindowLong         	 Real Include:WinAPISysInternals.au3	 API Include:WinAPISysWin.au3
! Func:	_WinAPI_GetWindowRect         	 Real Include:WinAPISysInternals.au3	 API Include:WinAPISysWin.au3
! Func:	_WinAPI_GetWindowRgn          	 Real Include:WinAPIGdiInternals.au3	 API Include:WinAPIGdi.au3
! Func:	_WinAPI_GetWindowText         	 Real Include:WinAPISysInternals.au3	 API Include:WinAPISysWin.au3
! Func:	_WinAPI_GetWindowThreadProcessId	 Real Include:WinAPISysInternals.au3	 API Include:WinAPISysWin.au3
! Func:	_WinAPI_GetWindowWidth        	 Real Include:WinAPISysInternals.au3	 API Include:WinAPISysWin.au3
! Func:	_WinAPI_InProcess             	 Real Include:WinAPISysInternals.au3	 API Include:WinAPISysWin.au3
! Func:	_WinAPI_InvalidateRect        	 Real Include:WinAPISysInternals.au3	 API Include:WinAPISysWin.au3
! Func:	_WinAPI_IsAlphaBitmap         	 Real Include:WinAPIGdiInternals.au3	 API Include:WinAPIGdi.au3
! Func:	_WinAPI_IsClassName           	 Real Include:WinAPISysInternals.au3	 API Include:WinAPISysWin.au3
! Func:	_WinAPI_IsWindow              	 Real Include:WinAPISysInternals.au3	 API Include:WinAPISysWin.au3
! Func:	_WinAPI_IsWindowVisible       	 Real Include:WinAPISysInternals.au3	 API Include:WinAPISysWin.au3
! Func:	_WinAPI_IsWow64Process        	 Real Include:WinAPIInternals.au3	 API Include:WinAPIProc.au3
! Func:	_WinAPI_LoadImage             	 Real Include:WinAPIInternals.au3	 API Include:WinAPIRes.au3
! Func:	_WinAPI_LoadLibrary           	 Real Include:WinAPIInternals.au3	 API Include:WinAPIRes.au3
! Func:	_WinAPI_MoveWindow            	 Real Include:WinAPISysInternals.au3	 API Include:WinAPISysWin.au3
! Func:	_WinAPI_PathIsDirectory       	 Real Include:WinAPIInternals.au3	 API Include:WinAPIFiles.au3
! Func:	_WinAPI_PtInRect              	 Real Include:WinAPIGdiInternals.au3	 API Include:WinAPIGdi.au3
! Func:	_WinAPI_ReadFile              	 Real Include:WinAPIInternals.au3	 API Include:WinAPIFiles.au3
! Func:	_WinAPI_RedrawWindow          	 Real Include:WinAPIGdiInternals.au3	 API Include:WinAPIGdi.au3
! Func:	_WinAPI_SetFocus              	 Real Include:WinAPISysInternals.au3	 API Include:WinAPISysWin.au3
! Func:	_WinAPI_SetFont               	 Real Include:WinAPISysInternals.au3	 API Include:WinAPISysWin.au3
! Func:	_WinAPI_SetParent             	 Real Include:WinAPISysInternals.au3	 API Include:WinAPISysWin.au3
! Func:	_WinAPI_SetWindowPos          	 Real Include:WinAPISysInternals.au3	 API Include:WinAPISysWin.au3
! Func:	_WinAPI_SetWindowRgn          	 Real Include:WinAPIGdiInternals.au3	 API Include:WinAPIGdi.au3
! Func:	_WinAPI_SetWindowText         	 Real Include:WinAPISysInternals.au3	 API Include:WinAPISysWin.au3
! Func:	_WinAPI_ShowWindow            	 Real Include:WinAPISysInternals.au3	 API Include:WinAPISysWin.au3
! Func:	_WinAPI_StrLen                	 Real Include:WinAPIInternals.au3	 API Include:WinAPIMisc.au3
! Func:	_WinAPI_SwitchColor           	 Real Include:WinAPIInternals.au3	 API Include:WinAPIGdi.au3
! Func:	_WinAPI_UpdateWindow          	 Real Include:WinAPISysInternals.au3	 API Include:WinAPISysWin.au3
! Func:	_WinAPI_WriteFile             	 Real Include:WinAPIInternals.au3	 API Include:WinAPIFiles.au3

Attachments (0)

Change History (7)

comment:1 Changed 3 months ago by Jos

  • Description modified (diff)

comment:2 Changed 3 months ago by Jpm

Hi,
*Internals.au3 are meant to be used in several *.au3 so it is an error if only if the *.au3 is not referring a *internals.au3

Can you point out to such cases?

basically function description will never point to an *Internals.au3

comment:3 Changed 3 months ago by Jos

JP,
when you think it is fine to point to another include than the actual include containing the Func, you can close this ticket and it simply means I can't trust the content of au3.api and will have to sort their proper location myself via a script as I ended up doing.
I need the exact include file for the Jump-To-Func functionality in SciTE-Lua. ;)

Jos

Last edited 3 months ago by Jos (previous) (diff)

comment:4 Changed 3 months ago by Jpm

I will check what I can do without disturbing the Doc generation.
The doc must point to the main include

comment:5 Changed 3 months ago by Jos

JP,
Just leave things as they were and don't worry about it. I have worked around this "issue" for the requirement I have and made in such way that the Include from au3.api will be inserted and Jump-to-Func will go to the proper Include file as there is no other option there. :)

comment:6 Changed 3 months ago by Jpm

is the creation of au3.api still needed?
I assume Scite Lite is using it?

comment:7 Changed 3 months ago by Jos

  • Resolution set to No Bug
  • Status changed from new to closed

Yes the creation is still required as the standard AutoComplete of AutoIt3.

Closing this issue as "working as intended". :)

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.