Modify

Opened 12 years ago

Closed 12 years ago

#398 closed Bug (No Bug)

Compiles Scripts won't run with Config of exact same name

Reported by: ChrisA Owned by:
Milestone: Component: AutoIt
Version: 3.2.12.1 Severity: None
Keywords: Cc:

Description

Our company's naming convention for configuration files is ProgramName.exe.config - so following the company standards I named a script's config file AutoUpdateTMC.exe.config.

When I compile the script it makes the exe without any issues.

When I run the exe I get an error that states:

The Application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem.

If I rename either the AutoUpdateTMC.exe or the AutoupdateTMC.exe.config to anything else it works.

So I decided to go back to conventional names and simply called the config AutoUpdateTMC.config and now it works fine.

Attachments (0)

Change History (1)

comment:1 Changed 12 years ago by Valik

  • Resolution set to No Bug
  • Status changed from new to closed

This is not a bug. Windows looks for a file with the name appname.exe.config. See here for what the file is for. Your companies naming policy is poor and should be changed. The simplest way to fix it is to stop using "config" as the extension ans use "cfg".

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.