Modify

Opened 12 years ago

Closed 12 years ago

#417 closed Bug (No Bug)

Changing function parameters on a function call

Reported by: serg Owned by:
Milestone: Component: AutoIt
Version: 3.2.13.3 Severity: None
Keywords: Cc:

Description

The folowing script consists of two files:
HTTP_UDF.au3:

#include "XMLDomWrapper\_XMLDomWrapper.au3"

Func __HTML_Navigate($sURL, $sUName = "", $sPass = "", $sParam = "", $sMethod = "GET")

[...]
		_XMLFileOpen($sHTMLFile)
		; At that place is $sHTMLFile = "F:\Archiv5\SERG\Development\AutoItScripts\ScriptsSVN\Libs\HTML_UDF\Html_zmzlvdd.tmp"
	EndIf
EndFunc

And _XMLDomWrapper.au3 by Stephen Podhajecki VER:1.0.3.87 :

Func _XMLFileOpen($strXMLFile, $strNameSpc = "", $iVer = -1, $bValOnParse = True)
	; Now $strXMLFile = "F:Erchiv5rERGEevelopmenteutoItScriptsucriptsSVNcibsiTML_UDFTtml_zmzlvdd.tmp"

[...]

EndFunc   ;==>_XMLFileOpen

At no one place the value of $sHTMLFile or $strXMLFile was changed.
Only the simple call of _XMLFileOpen with $sHTMLFile as $strXMLFile parameter is changing the value.

Attachments (0)

Change History (2)

comment:1 Changed 12 years ago by serg

Sorry, it's not a bug, my mistake.

comment:2 Changed 12 years ago by Gary

  • Resolution set to No Bug
  • Status changed from new to closed

Not a part of the Standard UDFs either.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.