Modify

Opened 12 years ago

Closed 12 years ago

#430 closed Bug (Duplicate)

Deleting disabled image controls hard crashes AutoIt

Reported by: koshyjohnuk@… Owned by:
Milestone: Component: AutoIt
Version: 3.2.13.0 Severity: None
Keywords: Disabled image, hard crash, delete control Cc:

Description

The summary and the following code should be enough to understand the problem. Please take any image file say "example.jpg" and put it in the same directory as the script - if the file does not exist, the crash won't occur.

Global Const $GUI_DISABLE = 128
Local $msg
Local $tp = @TempDir
Local $ginstall = GUICreate("installer",420,375)

Local $b_yes = GUICtrlCreateButton ("Yes",235,335,80,26)
FileInstall("example.jpg",$tp &"\top",1)
Local $i_img = GUICtrlCreatePic ($tp &"\top",0,52,420,270)
GuiCtrlSetState(-1,$GUI_DISABLE) ;$i_img IS NOW DISABLED
GUISetState()
		
While 1
	$msg = GUIGetMsg ()
	Switch $msg
		Case $b_yes
			GUICtrlDelete($i_img) ;CRASH AT THIS POINT
			GUICtrlDelete($b_yes)
			ExitLoop
	EndSwitch
WEnd

And if it is of any use, here's the information given by Windows:

Problem Event Name: APPCRASH

Application Name: AutoIt3.exe
Application Version: 3.2.12.0
Application Timestamp: 482d38b9
Fault Module Name: AutoIt3.exe
Fault Module Version: 3.2.12.0
Fault Module Timestamp: 482d38b9
Exception Code: c0000005
Exception Offset: 0003c4e5
OS Version: 6.0.6001.2.1.0.768.3
Locale ID: 1033
Additional Information 1: fd00
Additional Information 2: ea6f5fe8924aaa756324d57f87834160
Additional Information 3: fd00
Additional Information 4: ea6f5fe8924aaa756324d57f87834160

Attachments (0)

Change History (8)

comment:1 Changed 12 years ago by TicketCleanup

  • Severity changed from Blocking to None

Automatic ticket cleanup.

comment:2 Changed 12 years ago by Gary

Doesn't crash for me in 3.2.12.1 release or 3.2.13.3 beta

comment:3 Changed 12 years ago by koshyjohnuk

Installed 3.2.12.1
The crash still occurs:

Problem signature:

Problem Event Name: APPCRASH
Application Name: AutoIt3.exe
Application Version: 3.2.12.1
Application Timestamp: 4850e379
Fault Module Name: AutoIt3.exe
Fault Module Version: 3.2.12.1
Fault Module Timestamp: 4850e379
Exception Code: c0000005
Exception Offset: 0003c4b4
OS Version: 6.0.6001.2.1.0.768.3
Locale ID: 1033
Additional Information 1: fd00
Additional Information 2: ea6f5fe8924aaa756324d57f87834160
Additional Information 3: fd00
Additional Information 4: ea6f5fe8924aaa756324d57f87834160

I'm running Windows Vista SP1 (Home Premium). I installed 3.2.12.1 and restarted the system just to be doubly sure. Ran the code and as before, it just crashed immediately after pressing 'Yes'.

The crash does NOT occur if I comment out the 'GuiCtrlSetState(-1,$GUI_DISABLE)' line. It happened in a much bigger program and I distilled it down to the above code.

The crash occurs EVEN if I re-enable the control using 'GuiCtrlSetState($i_img,$GUI_ENABLE)' and then try to delete it. The exception code and offset in the error details given by windows remain the same.

comment:4 Changed 12 years ago by Gary

hmmm, don't have sp1 to test, I'm on WinXP Pro SP3

comment:5 Changed 12 years ago by koshyjohnuk

Is any other developer with Vista going to look at this? Or is there any other information that I can provide which will help with diagnosis?

comment:6 Changed 12 years ago by jpm

for the time being as my notebook is broken I have no access to Vista Sp1.
I cannot reproduce it with XP Sp2. As soon I have my notebook repaired I will analyse the problem.

comment:7 Changed 12 years ago by jpm

the problem has been solved in 3.2.13.0 see ticket #339

comment:8 Changed 12 years ago by Jpm

  • Resolution set to Duplicate
  • Status changed from new to closed
  • Version changed from 3.2.12.0 to 3.2.13.0

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.