Modify

Opened 12 years ago

Closed 12 years ago

#433 closed Bug (No Bug)

Au3Check unexpected behaviour

Reported by: TomZ (tom.vd.zanden /at\ gmail D0T c[]m) Owned by: Jos
Milestone: Component: SciTE4AutoIt
Version: 3.2.12.0 Severity: None
Keywords: Cc:

Description

some_function()

Func some_function()
	_helper_function()
EndFunc

Func bogus_function()
	(
EndFunc

Func _helper_function()
EndFunc
+>13:29:55 Starting AutoIt3Wrapper v.1.10.1.8    Environment(Language:0413  Keyboard:00020409  OS:WIN_XP/Service Pack 2  CPU:X86)
>Running AU3Check (1.54.13.0)  from:bug.au3(8,2) : ERROR: syntax error
	(
	^
bug.au3(4,19) : ERROR: _helper_function(): undefined function.
	_helper_function()
	~~~~~~~~~~~~~~~~~^
bug.au3 - 2 error(s), 0 warning(s)
!>13:29:55 AU3Check ended.rc:2
>Exit code: 0    Time: 2.457

Due to the unbalanced brackets in bogus_function, _helper_function is reported as undefined, while it isn't. This is slightly confusing, making debugging harder. Moving _helper_function above bogus_function eliminates this problem.

Attachments (0)

Change History (1)

comment:1 Changed 12 years ago by Valik

  • Resolution set to No Bug
  • Status changed from new to closed

This is not a bug. You should only look at the top error, fix it, re-check and move on. Things like syntax errors can throw off the check because they are syntax errors which means the script is malformed.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The owner will remain Jos.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.