Modify

Opened 12 years ago

Closed 12 years ago

#453 closed Bug (No Bug)

ControlSend dont work properly

Reported by: h3ir Owned by:
Milestone: Component: AutoIt
Version: 3.2.12.0 Severity: None
Keywords: controlsend properly dont work Cc:

Description

Full Thread: http://www.autoitscript.com/forum/index.php?showtopic=76409

I tried this thing:

ControlSend("Der Herr der Ringe Online: Schatten von Angmar", "", "", "c")

It doesnt work! When I Focus the Window like that:

ControlFocus ("Der Herr der Ringe Online: Schatten von Angmar", "", "")
ControlSend("Der Herr der Ringe Online: Schatten von Angmar", "", "", "c")

He sends the key, but the window ist focused

And this:

 Global $Window = WinGetTitle("[CLASS:CLIENT]")

While 1
Tryout()
WEnd

Func Tryout()
    While 1
    ControlSend($Window, "", "", "2")
    Exit
    ExitLoop
    WEnd
EndFunc

Doesnt work like the first thing...

Attachments (0)

Change History (1)

comment:1 Changed 12 years ago by Valik

  • Resolution set to No Bug
  • Status changed from new to closed

We only claim support for standard Microsoft controls. You're trying to send to a game or something. If it works, great, if not, well, sucks to be you. And in this case, it sucks to be you because this is certainly not a bug.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.