Modify

Opened 12 years ago

Closed 12 years ago

#470 closed Bug (No Bug)

Displaying '&' symbol in TraySetToolTip()

Reported by: anonymous Owned by:
Milestone: Component: AutoIt
Version: 3.2.12.0 Severity: None
Keywords: Cc:

Description

Below code will only display "hi" when mouse is placed onto of the tray icon.

TraySetToolTip("hi&")

I've tried escaping the '&' symbol, which isn't necessary, but doesn't work. Is this a bug? At least I think it is.

Attachments (0)

Change History (1)

comment:1 Changed 12 years ago by Valik

  • Resolution set to No Bug
  • Status changed from new to closed

This is not a bug. By default, Tooltip controls strip the ampersand character. You can either change the style of the tooltip to add the TTS_NOPREFIX style or you can triple the ampersand to get it to display.

TraySetToolTip("hi&&&")

The reason three ampersands are required is because it's double-escaping. The first escape is to prevent the ampersand from being stripped and the second escape shows a literal ampersand instead of underlining the next letter.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.