Modify

Opened 13 years ago

Closed 13 years ago

#512 closed Bug (No Bug)

Runas problem with new version.

Reported by: anonymous Owned by:
Milestone: Component: AutoIt
Version: 3.2.12.0 Severity: None
Keywords: Cc:

Description

Hello I write a program when coulndt run correctly I have tried with that simple code.
When I start the program installation is starting and it is saying you are not administrator. But I used Local Administrator or domain administrator. nothing changed. so I tried to another pc and other version (v3.2.12.0). In my computer I have v3.2.12.1 and also I tried with beta. I have installed v3.2.10.0 to clear computer it worked well I updated v3.2.12.1 . It couldnt work again.

I have tried it in my home pc. Same problem.

If Not IsAdmin() Then
RunAs('username', "Domain", 'Password',0,@ComSpec,@SystemDir)

RunWait("c:\install_flash_player.exe")
MsgBox(0,"","complate")
EndIf

Attachments (0)

Change History (1)

comment:1 Changed 13 years ago by Valik

  • Resolution set to No Bug
  • Status changed from new to closed

Well, if the caller is a non-administrator account and the Flash Player installer requires administrator rights, then the error is correct because you use RunWait() to call the installer.

At any rate, I don't see anything wrong, I know RunAs[Wait]() works with that simple code (when written correctly), so I'm closing this as no bug.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.