Modify

Opened 12 years ago

Closed 12 years ago

#543 closed Bug (No Bug)

Autoit does not automate high res mouse motion correctly.

Reported by: anonymous Owned by:
Milestone: Component: AutoIt
Version: 3.2.12.0 Severity: None
Keywords: mouse motion Cc:

Description

The program I am trying to automate appears to use the directx high res mouse input for control. Autoit seems to send the same relative data when moving even though the absolute mouse position is correct. To reproduce the problem use the program Future Pinball and press F11 to get into manual camera mode in full screen and then use autoit to create a mouse motion to attempt to center the pinball table on screen. Autoit will move the table in the same direction regardless of what coordinates are scripted for the movement. Only the mouse motion duration/speed effects the distance the camera is moved but not direction. Real mouse movement can properly center a table. hyperlinks references removed due to spam filter.

Attachments (0)

Change History (3)

comment:1 Changed 12 years ago by Jpm

Please attached a repro script. Without using "Future Pinball" will be better, as we usely don't install extra software when debugging a report problem.
Thanks

comment:2 Changed 12 years ago by anonymous

After disassembly of the application it looks like Autoit is doing the correct thing and Future Pinball is doing some bad signed/unsigned/zero boundry math on the mouse coords. I will work on getting it fixed.

comment:3 Changed 12 years ago by Jos

  • Resolution set to No Bug
  • Status changed from new to closed

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.