Modify

Opened 12 years ago

Closed 12 years ago

#547 closed Bug (No Bug)

WinGetHandle and WinGetTitle under Vista

Reported by: Developer@… Owned by:
Milestone: Component: AutoIt
Version: 3.2.13.7 Severity: None
Keywords: Vista Cc:

Description

Under Vista, the WinGetHandle function does not return the handle of a window belonging to a process owned by another user. ProcessExists does, however, return the PID of the process. ProcessList also "sees" the processes owned by another user.

Log on as User01. Launch Notepad.exe.

Via Fast User Switching, log on as User02.

A simple script asking "Does process notepad.exe exists" will return the PID of the notepad process owned by User01. However, neither WinGetHandle (see help documentation) or WinGetTitle running under User02 can "see" the windows to the notepad.exe owned by User01.

Attachments (0)

Change History (1)

comment:1 Changed 12 years ago by Valik

  • Resolution set to No Bug
  • Status changed from new to closed

The reason is the windows are running on a different desktop. This is expected and is not a bug.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.