Modify

Opened 12 years ago

Closed 12 years ago

#552 closed Bug (No Bug)

ProcessExist/ProcessList optional username parameter

Reported by: Developer@… Owned by:
Milestone: Component: AutoIt
Version: 3.2.12.0 Severity: None
Keywords: Cc:

Description

ProcessExist and ProcessList could provide an optional username parameter to limit the search to processes owned by a given user. Using the PID returned by these funtions, the other process functions could be effectively limited to processes owned by a given user by specifying the PID as opposed to the process name.

$PID = ProcessExists ("notepad.exe", @UserName)

This thread:

http://www.autoitscript.com/forum/index.php?showtopic=79434

discusses highlights the need.

Athough this may be accomplished using WMI, WMI is just too slow.

Attachments (0)

Change History (1)

comment:1 Changed 12 years ago by Valik

  • Resolution set to No Bug
  • Status changed from new to closed

This is not a bug and the need is over-stated a bit. Closing as no bug.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.