Modify

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#554 closed Bug (Fixed)

AutoIt3Wrapper not processing "&" in path properly

Reported by: dg0421 Owned by: Jos
Milestone: Future Release Component: SciTE4AutoIt
Version: 3.2.12.0 Severity: None
Keywords: Cc:

Description

My source files are contained in:
E:\ACE-IDS\XP & 2003 SLCD\Utilities\CoRAL\Include Files

You will notixed that the 2nd folder has an "&" ampersand contained in its name. This seems to be confusing the wrapper when it passes parameters to the Auto2Exe. In fact no parameters are successfully passed to Auto2Exe. I could change the folder name but I have other source files besides AutoIt contained in this folder structure that have links, so by changing the folder name I will loose the link, which would be a big pain.

Attachments (0)

Change History (4)

comment:1 Changed 11 years ago by anonymous

This issue was caused by outdated files. What happened was, I already had installed an AutoIt3 version from last year. A couple of days ago I installed the new SciTE (full version) that included AutoIt3Wrapper. It turns out that the AutoIt3Wrapper was issuing a command line parameter that wasn't compatible to version 3.2.8.1 of Aut2Exe. Specifically the command line parameter being issued by AutoIt3Wrapper was "/Pack" which isn't a valid parameter for version 3.2.8.1 of Aut2Exe. I have now upgraded to version 3.2.12.1 and all is well.

comment:2 Changed 11 years ago by anonymous

There was an issue with displaying the & in the source file text field in the GUI which will be fixed in the next release of AutoIt3Wrapper_GUI.

Jos

comment:3 Changed 11 years ago by Jos

  • Resolution set to Fixed
  • Status changed from new to closed

comment:4 Changed 11 years ago by TicketCleanup

  • Milestone set to Future Release

Automatic ticket cleanup.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The owner will remain Jos.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.