Modify

Opened 12 years ago

Closed 12 years ago

#567 closed Bug (No Bug)

missing function

Reported by: grzesiek Owned by:
Milestone: Component: Other
Version: 3.2.12.0 Severity: None
Keywords: Obfuscator Cc:

Description

Obfuscator does not add _GUICtrlListView_Sort() function to compiled script.

Example script:

#AutoIt3Wrapper_Run_Obfuscator=y
#Obfuscator_Parameters=/SO

#include <GuiListView.au3>
#include <GUIConstantsEx.au3>

$hGUI = GUICreate("")
$hListView = _GUICtrlListView_Create($hGUI, " ", 0, 0)
GUISetState()
_GUICtrlListView_RegisterSortCallBack($hListView)

Do
Until GUIGetMsg() = $GUI_EVENT_CLOSE

_GUICtrlListView_UnRegisterSortCallBack($hListView)

Attachments (0)

Change History (2)

comment:1 Changed 12 years ago by Polyphem

Thats not a bug, you told it to do so by setting the parameter

#Obfuscator_Parameters=/SO

so => striponly

comment:2 Changed 12 years ago by Valik

  • Resolution set to No Bug
  • Status changed from new to closed

Following up further, this is the reason stripping is and will not be a built-in feature. In the case where a function is a callback, you must tell the stripping mechanism not to strip the function because otherwise it will since it doesn't know it's being called.

This is not a bug.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.