Modify

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#574 closed Bug (Fixed)

Problem with sending the Windows Key + L

Reported by: Ainner Owned by: Valik
Milestone: 3.2.13.8 Component: AutoIt
Version: 3.2.12.1 Severity: None
Keywords: Cc:

Description

I'm using the Novell client.

Send("#l")

This lock the workstation but the "l" key doesn't work anymore unless I press the windows key to unlock it.

I tested it with an older version of AutoIt and it work no problem.

Attachments (0)

Change History (4)

comment:1 in reply to: ↑ description Changed 12 years ago by anonymous

Replying to Ainner:

I'm using the Novell client.

Send("#l")

This lock the workstation but the "l" key doesn't work anymore unless I press the windows key to unlock it.

comment:2 Changed 12 years ago by Asaman83687

I'm sorry Ainner but i Copy the code
you reported and it work with pure autoit version 3.2.12.1.
Maybe reinstalling may help.

comment:3 Changed 12 years ago by Valik

  • Milestone set to 3.2.13.8
  • Owner set to Valik
  • Resolution set to Fixed
  • Status changed from new to closed

Fixed in version: 3.2.13.8

comment:4 Changed 12 years ago by Valik

In 3.2.13.8 or later you will be able to avoid this problem with the following code:

Opt("SendKeyDelay", 0)
Opt("SendKeyDownDelay", 0)
Send("#l")

I've made changes so that setting the delay to 0 works as expected. The system is locked before the Windows key is released because of the built-in delays. The problem is a race condition which is why some people won't see it. This should virtually eliminate the issue although it's still theoretically possible it can still occur.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The owner will remain Valik.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.