Modify

Opened 12 years ago

Closed 12 years ago

#580 closed Bug (No Bug)

ControlListView - Get Text under SysListView32

Reported by: muskie88@… Owned by:
Milestone: Component: AutoIt
Version: 3.2.12.1 Severity: None
Keywords: Cc:

Description

ControlListView
_GUICtrlListView_GetItemTextString
_GUICtrlListView_GetItemText

All the above functions are not working when try to get string of "subitem 0" under uTorrent v1.8. Details and screen capture could be found:

http://www.autoitscript.com/forum/index.php?showtopic=80432

Attachments (0)

Change History (1)

comment:1 Changed 12 years ago by Valik

  • Resolution set to No Bug
  • Status changed from new to closed

As I explained in the forum post:
The list-view data is managed by the program itself (it has LVS_OWNERDATA set). That means data is not stored or accessed in the standard way. There is a second, different way to access the data and the code you are using does not try the alternate way. The control is what's called a "Virtual List-View" and you can find information on MSDN for how to work with it.

This is not a bug, closing it as such.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.