Modify

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#642 closed Bug (Fixed)

Beta helpfile not opening correctly

Reported by: Volly Owned by: Valik
Milestone: 3.2.13.10 Component: Documentation
Version: 3.2.12.0 Severity: None
Keywords: Cc:

Description

Process to reproduce issue:

  1. Run beta installer
  2. You will be asked to Show Release notes - click box to view them
  3. This will open the Beta Helpfile under the History / Change log section.
  4. AutoIt Help file opens to History / Change log
  5. Click on Contents tab
  6. Change to User Defined Functions - Not possible, for they are not there.

You have to close the help file, then reopen it to see that section of the helpfile.

A picture showing the problem can be found here:
http://www.autoitscript.com/forum/index.php?showtopic=83379

No big deal to fix, but if not fixed, the work around is pretty simple to do. Just making you aware of the issue.

Attachments (1)

autoit_error.JPG (28.3 KB) - added by Volly 11 years ago.
jpg showing helpfile problem

Download all attachments as: .zip

Change History (5)

Changed 11 years ago by Volly

jpg showing helpfile problem

comment:1 Changed 11 years ago by Valik

This technically isn't a bug, just not expected. The helpfile is actually 3 separate files. Two files contain the bulk of the information, one for AutoIt, one for UDF's. The third file is "merged" and really just loads up the other two. What's happening here is that AutoIt3.chm is being loaded instead of the merged file AutoIt.chm. Not really a bug, just something unexpected. Also something that should be easy to correct.

comment:2 Changed 11 years ago by Jpm

the correction will increase by 800K the setup file for very few improvement.
I suggest we stay as is.

comment:3 Changed 11 years ago by Valik

  • Milestone set to 3.2.13.10
  • Owner set to Valik
  • Resolution set to Fixed
  • Status changed from new to closed

Fixed in version: 3.2.13.10

comment:4 Changed 11 years ago by Valik

I really don't know what JP was thinking but this isn't that hard to do. It's not as straight-forward as I thought because of the merged helpfile. The problem is you can't open a topic in a slave.chm (AutoIt3.chm) via the master.chm (AutoIt.chm). For example, this doesn't work, you'll just get an error page:

hh.exe AutoIt.chm::/html/history.htm

However, the work-around is pretty simple. In the master.chm (AutoIt.chm) you create an alias to the slave.chm (AutoIt3.chm) topic:

[ALIAS]
IDH_History=ms-its:AutoIt3.chm::/html/history.htm

Then you create a map ID for the alias:

[MAP]
#define IDH_History 1000

Now you can use the -mapid command line argument of hh.exe to open the master (AutoIt.chm) and still go to a page in the slave.chm (AutoIt3.chm):

hh.exe -mapid 1000 AutoIt.chm

I'm posting this here because it's no big secret. I easily found out how to do it by searching the web. It may be useful to others if they use or are thinking about using merged helpfiles.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The owner will remain Valik.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.