Modify

Opened 11 years ago

Closed 11 years ago

#645 closed Feature Request (Completed)

IniDelete 3rd param doesn't accept Default keyword

Reported by: Rob Saunders <therks@…> Owned by: Valik
Milestone: 3.2.13.10 Component: AutoIt
Version: Severity: None
Keywords: inidelete default Cc:

Description

I was trying to write a wrapper for IniDelete and found I had to resort to an if statement, and two separate calls to IniDelete to allow it to delete whole sections.
Not sure if this is a bug or not, but it's unexpected behaviour on my part at least. A Simple repro of the "bug":

IniWrite(@tempdir & '\temp.ini', 'hello', 'world', 'foobar')
IniDelete(@tempdir & '\temp.ini', 'hello', Default)
ConsoleWrite(IniRead(@tempdir & '\temp.ini', 'hello', 'world', ''))

Console should be empty but instead we get "foobar" back.

Bug or feature request I'm not sure.

Attachments (0)

Change History (7)

comment:1 follow-up: Changed 11 years ago by Jpm

  • Resolution set to No Bug
  • Status changed from new to closed

as stated in "Default keyword" doc

When used as a parameter passing the behavior is specify in the corresponding AutoIt doc function.

so Default is not in use in this function so it converted to "Default" so the IniDelete is just erasing something which does not exist and return 1 as after completion the .ini does not anymore such key !!!

Perhaps after Valik rewrite this can change.

comment:2 Changed 11 years ago by Jpm

as stated in "Default keyword" doc

When used as a parameter passing the behavior is specify in the corresponding AutoIt doc function

sorry for these bad display

comment:3 in reply to: ↑ 1 ; follow-up: Changed 11 years ago by Valik

  • Resolution No Bug deleted
  • Status changed from closed to reopened

Replying to Jpm:

Perhaps after Valik rewrite this can change.

Or I could just change it now since supporting the Default keyword has nothing to do with the INI implementation.

comment:4 Changed 11 years ago by Valik

  • Owner set to Valik
  • Status changed from reopened to assigned

comment:5 in reply to: ↑ 3 Changed 11 years ago by Jpm

Replying to Valik:

Replying to Jpm:

Perhaps after Valik rewrite this can change.

Or I could just change it now since supporting the Default keyword has nothing to do with the INI implementation.

so it is an improvement not a bug the closing of the bug was I think the rigth thing before deciding to improve as you suggest

comment:6 Changed 11 years ago by Valik

  • Type changed from Bug to Feature Request
  • Version 3.2.13.9 deleted

There. It's a feature request now.

comment:7 Changed 11 years ago by Valik

  • Milestone set to 3.2.13.10
  • Resolution set to Completed
  • Status changed from assigned to closed

Added in version: 3.2.13.10

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The owner will remain Valik.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.