Modify

Opened 11 years ago

Closed 11 years ago

#647 closed Bug (No Bug)

Compiler Parsing

Reported by: pdaughe Owned by:
Milestone: Component: AutoIt
Version: 3.2.13.9 Severity: None
Keywords: Parsing Cc:

Description

The following presents a problem particularly when using the Execute statement:

$A = 1
$A = $A +++++- 1
MsgBox (0, "Test", "A = " & $A)

No syntax or run-time error is given.

Attachments (0)

Change History (2)

comment:1 Changed 11 years ago by Rob Saunders <therks@…>

Interesting, you can have as many mixed up + and - as you want, but throw one * or / in there and it errors.

comment:2 Changed 11 years ago by Jpm

  • Resolution set to No Bug
  • Status changed from new to closed
$A = 1
$A = $A ++++- 1
$B = 1
$B = Execute("$B ++++- 1")
MsgBox (0, "Test", "A = " & $A & @crlf & "B = " & $B)

Execute produce the same value. So the problem is not related to Execute.
Back to the question Autoit works as parenthesis
$A + (+(+(+(- 1))))
so the result is correct whatever you are surprised of the behavior as I am.
You can find other case as Autoit works as in Polish notation (Jon say it is OK)

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.