Modify

Opened 11 years ago

Closed 11 years ago

#651 closed Bug (No Bug)

FileFindFirstFile FileFindNextFile _FileListToArray not support mulit-byte folder name

Reported by: RobinHoo Owned by:
Milestone: Component: AutoIt
Version: 3.2.13.9 Severity: None
Keywords: Chinese Folder FileFindNextFile Cc:

Description

Once ran the the script under Chinese Windows XP SP3, found the _FileListToArray not working. After troubleshooting found the problem was in the folder name in Chinese. The most strage thing is the same folder name, which is in Chinese too, works in English Windows XP SP3. Checked the source code of _FileListToArray, got known that the problem caused by FileFindNextFile. No source code for FileFindNextFile, not sure the root cause of it. Pls try to check or send me the source code of FileFindNextFile, I can check for you, since the environment maybe not easy to rebuild. Thanks for your attention, and look forward your reply on it.

Thanks
Best Regards
Robin Hoo

Attachments (0)

Change History (3)

comment:1 Changed 11 years ago by Valik

Yeah, I don't really think we're going to be sending out the source code to our program. So, with that in mind, how can this issue be reproduced? Unless you're running AutoIt3A.exe (The ANSI version) by mistake, I don't see why it wouldn't work correctly because all the code is UNICODE.

comment:2 Changed 11 years ago by Jpm

If you really run 3.2.13.9 you run the UNICODE Version.
But as you debug you could have documented :
the $sPath and $sFilter value used by FileFindFirstFile,
the @error code you get after the FileFindNextFile
You can imagine we are not able to run the Chinese Windows version to reproduce

comment:3 Changed 11 years ago by Valik

  • Resolution set to No Bug
  • Status changed from new to closed

Closing due to lack of information.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.