Modify

Opened 11 years ago

Closed 11 years ago

#657 closed Bug (No Bug)

_IECreate brings up Outlook Express instead of Internet Explorer

Reported by: danarhea@… Owned by:
Milestone: Component: AutoIt
Version: 3.2.12.1 Severity: None
Keywords: Cc:

Description

Downloaded the latest build yesterday (not beta version)

My script seems to hang for a minute, and when the icon disappears, Outlook Express is started. My script is as follows:

#include <IE.au3>

$d3=filereadline ("logitc.vtr",3)
$d4=filereadline ("logitc.vtr",4)


$oIE = _IECreate ($d3)
_IEPropertySet($oIE,"theatermode", true)
_IELoadWait ($oIE)

$array=StringSplit($d4, ",")

for $i=1 to $array[0] step 2
  sleep(20)

  select 
    case $array[$i] = "D"
      Send ($array[$i+1])


    case  $array[$i] = "T"
       for $j=1 to $array[$i+1]
         send ("{TAB}")
       next

    case $array[$i] = "E"
       Send ("{ENTER}") 
       _IELoadWait ($oIE)

  endselect
next

Variable $d3 contains a url
Variable $d4 contains a command stream delimited by commas

Example:
T,11,D,<username>,T,1,D,<password>,E,0

The T denotes that the next variable is number of tabs.
The D denotes that the next variable is data to be sent to a form.
The E denotes the Enter Key (the zero afterwards is only a filler).

The file "logitc.vtr" is created with a Delphi program, based on which web site is chosen to navigate to (read as $d3 by the script), and the commands to use in order to move around the form and submit it (read as $d4). After creating the file, the Delphi program calls the autoit executable, which reads the file, and processes the commands. The problem is in the autoit executable. I have also ran the script directly, and have the same problem.

Both the Delphi program and the autoit executable work under an older version of autoit.

Attachments (0)

Change History (2)

comment:1 Changed 11 years ago by Valik

You need to narrow the script down further. Surely you must have a specific URL that you can hard-code for reproduction purposes. And if the problem is really in _IECreate() then you don't need any of those Send() statements.

Are you certain you aren't just accidentally Send()'ing to the Desktop or something and running an Outlook shortcut?

comment:2 Changed 11 years ago by Valik

  • Resolution set to No Bug
  • Status changed from new to closed

Closing due to lack of information.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.