Modify

Opened 11 years ago

Closed 11 years ago

#677 closed Feature Request (Works For Me)

ControlGetHandle/ControlListView on .Net Listview crashes/not working with Vista64

Reported by: freakazoid Owned by: Jon
Milestone: Component: AutoIt
Version: Severity: None
Keywords: Cc:

Description

Sample Application: http://www.ondotnet.com/dotnet/2002/10/28/examples/listview-example.zip from http://www.ondotnet.com/pub/a/dotnet/2002/10/28/listview.html?page=2

I had this problem also with other programs using listview and another user reporting the same.

Sample script:

msgbox (0, "", "started");
$captcha_window_handle = WinGetHandle("C:\temp\listview");
msgbox (0, "", "we got the windowhandle: "&$captcha_window_handle);
$captchahandle = ControlGetHandle ($captcha_window_handle,"","[CLASS:WindowsForms10.SysListView32.app.0.378734a; INSTANCE:1]");		
msgbox (0, "", "we got the controlhandle:" &$captchahandle);
$value = ControlListView($captcha_window_handle,"",$captchahandle,"GetText",0,0);		
msgbox (0, "", "controllistview value:"&$value);

The sample app uses the path you run it in as windowtitle, so the second line needs to be set to your local settings. The script runs fine and without any issues on WinXP32, but on Vista64 the ControlGetHandle fails to return any handle or if successful it crashes the target app when using ControlListView.

I've tried this with the last beta and current release version, same negative effect.

Attachments (0)

Change History (6)

comment:1 Changed 11 years ago by Valik

  • Severity changed from None to Blocking

comment:2 Changed 11 years ago by TicketCleanup

  • Severity changed from Blocking to None

Automatic ticket cleanup.

comment:3 Changed 11 years ago by Valik

  • Owner set to Jon
  • Severity changed from None to Blocking
  • Status changed from new to assigned

comment:4 Changed 11 years ago by Jon

  • Severity changed from Blocking to None
  • Type changed from Bug to Feature Request

The problem is these functions rely on sharing memory between processes. Need to look at a way to share memory between a 32 and 64 process ok. Changing to feature request.

comment:5 Changed 11 years ago by TicketCleanup

  • Version 3.2.13.10 deleted

Automatic ticket cleanup.

comment:6 Changed 11 years ago by Jpm

  • Resolution set to Works For Me
  • Status changed from assigned to closed

Checking with 3.3.0.0 running under a Vista X64 under a Virtual machine Works for me

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The owner will remain Jon.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.