Modify

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#689 closed Bug (No Bug)

@DesktopDir macro introduces unwanted characters at times.

Reported by: sanchezconsulting@… Owned by:
Milestone: Component: AutoIt
Version: 3.2.12.1 Severity: None
Keywords: Cc:

Description

Under Windows Vista, the @DesktopDir macro sometimes "shifts" certain characters. For example, the ":" may get down shifted to a ";", while the "\" may get up shifted to "|"

This happens under Windows Vista English US, English Canada, French Canada and Spanish Latin America languages. The versions of Vista range from Home Premium to Ultimate with both 32- and 64-bit versions. The defect seems to be random.

The @DesktopDir macro was used to create a variable that contained a file name, and then ControlSend() was used to send the variable to a "Save As" window's edit box, so it could be a combination of both @DesktopDir and ControlSend()

Attachments (0)

Change History (2)

comment:1 follow-up: Changed 11 years ago by Valik

  • Resolution set to No Bug
  • Status changed from new to closed

You do realize this has nothing to do with @DesktopDir, right? That all that macro does is return a string? I don't think you do know that since you don't bother to actually state what the contents of @DesktopDir are.

Chances are, something is messing with the keyboard state. Barring that, send the characters in raw mode. This is almost certainly not a bug and even if there is a bug I can pretty much guarantee it's not with @DesktopDir.

If either of the two comments I made are not helping then post on the forum. You need support, not a fix in AutoIt.

comment:2 in reply to: ↑ 1 Changed 11 years ago by sanchezconsulting@…

Replying to Valik:

You do realize this has nothing to do with @DesktopDir, right? That all that macro does is return a string? I don't think you do know that since you don't bother to actually state what the contents of @DesktopDir are.

Chances are, something is messing with the keyboard state. Barring that, send the characters in raw mode. This is almost certainly not a bug and even if there is a bug I can pretty much guarantee it's not with @DesktopDir.

If either of the two comments I made are not helping then post on the forum. You need support, not a fix in AutoIt.

Valik,

I understand what the @ macros do, and this issue seems to actually arise when in combination with Vista, and NOT using the #RequireAdmin directive while using BlockInput(). While the error arose due to my "ignorance" of using BlockInput() without #RequireAdmin under Vista, and while these are probably rare circumstances, I figure that it would be worth reporting...then again, shouldn't this be a concern taken into consideration?

I wrote a test script that opens "Notepad" and a for loop ControlSends the @DesktopDir to the text window. I put in BlockInput(1) at the beginning of the string without a #RequireAdmin, and the problem doesn't present itself under XP. Run the script under Vista, and the problem pops up randomly. So, I guess you're right, I didn't know that #RequireAdmin was needed in order to use BlockInput(), but that still leaves an issue that this "strange" combination is causing weird output from the @DesktopDir macro...which of course could be happening with other macros, but I ain't gonna check that.

I guess the "bug" was not a but and should be left as closed, and I'll just figure out another way to do what I wanted it to do.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.