Modify

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#697 closed Bug (No Bug)

Process Close Randomly Not Working

Reported by: kjcdude@… Owned by:
Milestone: Component: AutoIt
Version: 3.2.13.11 Severity: None
Keywords: ProcessClose Cc:

Description

I run my scripts on over 600 PCs and have been running this portion of the script every other night for 9 months and have only seen an issue in v3.2.13.11.

On ~1/15 pcs when this portion of the script is ran the process is not actually closed.
Here's the portion of the script.

ProcessClose("Gw.exe")

Here's the entire file.

If FileExists("C:\Program Files\Guild Wars\Gw.exe") Then
	run("C:\Program Files\Guild Wars\Gw.exe")
	sleep(5000)
EndIf
if ProcessExists("Gw.exe") = 0 Then
	DirCopy("Y:\Guild Wars", "C:\Program Files\Guild Wars", 1)
	RegWrite("HKEY_LOCAL_MACHINE\SOFTWARE\ArenaNet\Guild Wars", "Path", "REG_SZ", "C:\Program Files\Guild Wars\Gw.exe")
	RegWrite("HKEY_LOCAL_MACHINE\SOFTWARE\ArenaNet\Guild Wars", "SRC", "REG_SZ", "C:\Program Files\Guild Wars\Gw.exe")
Else
	sleep(60000)
	ProcessClose("Gw.exe")
EndIf

Attachments (0)

Change History (3)

comment:1 Changed 11 years ago by Valik

  • Resolution set to No Bug
  • Status changed from new to closed

That's nice. Now, create a thread in support and talk about the issue with others who can help you. You've given no useful information at all. You've also posted code without any error checking so as far as I can tell you have no proof the code is even flowing how you think it is.

At any rate, I find it unlikely this is actually a bug in AutoIt. Even if it is a bug in AutoIt, you haven't provided any information to reproduce it. So I'm closing this.

comment:2 follow-up: Changed 11 years ago by kjcdude@…

The bug that i have found is reproducible. As i stated it's random.

ProcessClose("Gw.exe") works within v3.2.13.10 and earlier, but not with v3.2.13.11.

It's a very simple error that I'm encountering and i have provided all the information i have. Sorry for wasting your time.

comment:3 in reply to: ↑ 2 Changed 11 years ago by Valik

Replying to kjcdude@…:

The bug that i have found is reproducible. As i stated it's random.

Is it random or is it reproduceable? It can't be both. It can't be random, either, because nothing in computers is random. But it might be under some incredibly obscure circumstance. Without knowing what that circumstance is there is nothing that can be done to remedy it.

ProcessClose("Gw.exe") works within v3.2.13.10 and earlier, but not with v3.2.13.11.

Nothing was changed between those two versions that would affect ProcessClose().

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.