Modify

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#716 closed Bug (No Bug)

decimal subtraction bug

Reported by: mmavipc Owned by:
Milestone: Component: AutoIt
Version: 3.2.12.1 Severity: None
Keywords: Cc:

Description

MsgBox(0,"",7.04-7 & " " & 8.04-8)
7.04-7=0.04
8.04-8=0.0399999999999991
hmm I wonder that is wrong with that

Attachments (0)

Change History (3)

comment:1 Changed 11 years ago by TicketCleanup

  • Severity changed from Blocking to None

Automatic ticket cleanup.

comment:2 in reply to: ↑ description Changed 11 years ago by Valik

  • Resolution set to No Bug
  • Status changed from new to closed

Replying to mmavipc:

MsgBox(0,"",7.04-7 & " " & 8.04-8)
7.04-7=0.04
8.04-8=0.0399999999999991
hmm I wonder that is wrong with that

Nothing is wrong with it. Just like #715, this is not a bug. Floating point numbers are not precise. There is a ton of literature on the internet about it. I've explained it countless times.

comment:3 Changed 11 years ago by Valik

Since I found one of the threads where I explain it, here is the link.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.