Modify

Opened 12 years ago

Closed 12 years ago

#72 closed Bug (No Bug)

MFC ActiveX Control doesn't work w/ AutoIt

Reported by: livewire Owned by:
Milestone: Component: AutoIt
Version: 3.2.10.0 Severity:
Keywords: mfc activex control Cc:

Description

MFC ActiveX controls' properies and methods cannot be accessed/invoked via AutoIt. These same controls can be accessed/invoked via VB6 and the ActiveX Control Test Container that comes with Visual Studio 6.

I would expect that if I create an MFC ActiveX Control, I would be able to access/invoke the properties and methods.

You can reproduce the bug by following my instructions on the link below.

OS: Windows XP SP2

Here is a link to my topic on the support forum which contains a sample MFC ActiveX Control:
http://www.autoitscript.com/forum/index.php?showtopic=61095&hl=livewire

Thanks,
Livewire

Attachments (0)

Change History (2)

comment:1 Changed 12 years ago by livewire

...forgot to provide some sample code...the following code sample fails if the line is uncommented.

#include <GUIConstants.au3>

$Form1 = GUICreate("Plot Sample", 443, 386, 193, 115)
$PlotObj = ObjCreate("PLOT.PlotCtrl.1")
$PlotObj_ctrl = GUICtrlCreateObj($PlotObj, 32, 8, 376, 328)
$PlotObj_event = ObjEvent($PlotObj,"PlotEvent_")

GUISetState(@SW_SHOW)
;$PlotObj.AboutBox()
While 1
	$nMsg = GUIGetMsg()
	Switch $nMsg
		Case $GUI_EVENT_CLOSE
			Exit
	EndSwitch
WEnd

comment:2 Changed 12 years ago by Valik

  • Resolution set to nobug
  • Status changed from new to closed

The object does not implement IDispatch. Objects must properly implement IDispatch in order for AutoIt to use them. This is not a bug.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.