Modify

Opened 11 years ago

Closed 11 years ago

#726 closed Bug (No Bug)

Statusbar not visible in a window created with $ws_popup and with a menu

Reported by: charvi Owned by:
Milestone: Component: AutoIt
Version: 3.2.12.1 Severity: None
Keywords: Cc:

Description

I have discovered that the statusbar is not visible when a window is created with $ws_popup and with a menu.

#include <ButtonConstants.au3>
#include <EditConstants.au3>
#include <GUIConstantsEx.au3>
#include <StaticConstants.au3>
#include <WindowsConstants.au3>
#include <GuiEdit.au3>
#include <GuiMenu.au3>
#include <GuiToolBar.au3>
#include <GuiComboBoxEx.au3>
#include <Array.au3>
#include <Constants.au3>
#include <WinAPI.au3>
#include <File.au3>

$hWin1 = GUICreate("Test", 1680, 1050, 0, 0, $ws_popup)
GUISetBkColor(0x838b83,$hWin1)
$mStatusBar = _GUICtrlStatusBar_Create($hWin1,-1)

	Dim $hFile = GUICtrlCreateMenu("&File")

GUISetState()

While 1
	$msg = GUIGetMsg()
	Select
		Case $msg = $gui_event_close
			ExitLoop
	EndSelect
WEnd

Attachments (0)

Change History (1)

comment:1 Changed 11 years ago by Valik

  • Resolution set to No Bug
  • Status changed from new to closed

You should always create the menu before creating any other control.

Not a bug.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.